experiencing a tech problem with replay of bmt webinars - futures io
futures io



experiencing a tech problem with replay of bmt webinars


Discussion in Tech Support

Updated
      Top Posters
    1. looks_one Big Mike with 9 posts (4 thanks)
    2. looks_two Superdoug3 with 5 posts (3 thanks)
    3. looks_3 josh with 2 posts (0 thanks)
    4. looks_4 V i m with 2 posts (1 thanks)
      Best Posters
    1. looks_one GridKing with 1 thanks per post
    2. looks_two Superdoug3 with 0.6 thanks per post
    3. looks_3 V i m with 0.5 thanks per post
    4. looks_4 Big Mike with 0.4 thanks per post
    1. trending_up 4,398 views
    2. thumb_up 10 thanks given
    3. group 5 followers
    1. forum 24 posts
    2. attach_file 0 attachments




Welcome to futures io: the largest futures trading community on the planet, with well over 125,000 members
  • Genuine reviews from real traders, not fake reviews from stealth vendors
  • Quality education from leading professional traders
  • We are a friendly, helpful, and positive community
  • We do not tolerate rude behavior, trolling, or vendors advertising in posts
  • We are here to help, just let us know what you need
You'll need to register in order to view the content of the threads and start contributing to our community.  It's free and simple.

-- Big Mike, Site Administrator

(If you already have an account, login at the top of the page)

 
Search this Thread
 

experiencing a tech problem with replay of bmt webinars

(login for full post details)
  #1 (permalink)
 Superdoug3 
Vernon, BC, Canada
 
Experience: Beginner
Platform: Sierra Charts
Broker: Zaner Group (Transact)
Trading: ES
 
Posts: 103 since Apr 2010
Thanks: 113 given, 63 received

Did anyone else have replay problems on futures.io (formerly BMT) webinars?
Specifically - the webinar is playing fine then skips backwards a minute or 2 and replays this. this happens at least a dozen times or more.

I have an I7 running Win7 HP 64 bit, 6G RAM, OCZ SSD drive, play back on WMP latest version

Actions take
1. called my ISP to check out the quality of my DSL feed
2. I ran speedtest.net and pingtest.net and got good results
3. Used a backup image of my system saved from several months back
4.Played webinars from other sites e.g. market delta, these played fine
5.checked webinar threads to see if any other traders complained about this

Observations
this seems to have started in last 3 months
this only seems to happen with futures.io (formerly BMT) webinars
I seem to be the only one with a problem

Reaching for ideas
As it seems to get worse closer towards the end of the webinar, could this be a buffer problem with WMP -

*****Big Mike is suggesting Google Chrome, I am currently running under IE 10 and so far so good, I will try Big Mike's suggestion

Started this thread Reply With Quote

Journal Challenge April 2021 results (now extended!):
Competing for $1800 in prizes from Jigsaw
looks_oneMaking a Living with the Microsby sstheo
(302 thanks from 30 posts)
looks_twoSalao's Journalby Salao
(80 thanks from 13 posts)
looks_3Deetee’s DAX Trading Journal (time based)by Deetee
(50 thanks from 20 posts)
looks_4Learning to Profit - A journey in algorithms and optionsby Syntax
(38 thanks from 16 posts)
looks_5Maybe a little bit different journalby Malykubo
(17 thanks from 18 posts)
 
Best Threads (Most Thanked)
in the last 7 days on futures io
The Crude Dude Oil Trading System
122 thanks
Big Mike in Ecuador
60 thanks
Help improve the FIO community
38 thanks
Next New Poll Ideas/Suggestions
20 thanks
www.isystems.com
16 thanks
 
(login for full post details)
  #3 (permalink)
 Big Mike 
Site Administrator
Swing Trader
Data Scientist & DevOps
Manta, Ecuador
 
Experience: Advanced
Platform: Custom solution
Trading: Futures & Crypto
 
Big Mike's Avatar
 
Posts: 50,014 since Jun 2009
Thanks: 32,474 given, 98,311 received


There are no problems being reported from anyone else, and everything works fine when I test here. Just make sure you are using the latest Flash.

Adobe - Install Adobe Flash Player

I have not tried IE10. It is in beta and I would rather not download it. IE is traditionally the worst browser in existence, so it wouldn't surprise me if there are major compatibility problems with it as there are always problems with IE of all versions.

You can use Firefox or Chrome to confirm it is an IE problem.

Mike

We're here to help -- just ask

For the best trading education, watch our webinars
Searching for trading reviews? Review this list

Follow us on Twitter, YouTube, and Facebook

Support our community as an Elite Member:
https://futures.io/elite/

Visit other sites? Please spread the word about your experience with our community!
Follow me on Twitter Visit my futures io Trade Journal Reply With Quote
The following user says Thank You to Big Mike for this post:
 
(login for full post details)
  #4 (permalink)
 Big Mike 
Site Administrator
Swing Trader
Data Scientist & DevOps
Manta, Ecuador
 
Experience: Advanced
Platform: Custom solution
Trading: Futures & Crypto
 
Big Mike's Avatar
 
Posts: 50,014 since Jun 2009
Thanks: 32,474 given, 98,311 received


Superdoug3 View Post
As it seems to get worse closer towards the end of the webinar, could this be a buffer problem with WMP -

Windows Media Player is not involved. The webinars are streamed from our site using RTMP and Flash.

Mike

We're here to help -- just ask

For the best trading education, watch our webinars
Searching for trading reviews? Review this list

Follow us on Twitter, YouTube, and Facebook

Support our community as an Elite Member:
https://futures.io/elite/

Visit other sites? Please spread the word about your experience with our community!
Follow me on Twitter Visit my futures io Trade Journal Reply With Quote
 
(login for full post details)
  #5 (permalink)
 Superdoug3 
Vernon, BC, Canada
 
Experience: Beginner
Platform: Sierra Charts
Broker: Zaner Group (Transact)
Trading: ES
 
Posts: 103 since Apr 2010
Thanks: 113 given, 63 received

No luck with your suggestions
1. updated Firefox to 13 and downloaded latest Adobe Flash player - still skipping backwards a minute or 2 and replaying on every futures.io (formerly BMT) webinar I try.
2. installed latest Google Chrome and latest Adobe Flash player - same symptom
3. I can live with this, I do appreciate your quick response

Started this thread Reply With Quote
 
(login for full post details)
  #6 (permalink)
 cory 
the coin hunter
virginia
 
Experience: Intermediate
Platform: ninja
Trading: NQ
 
cory's Avatar
 
Posts: 6,042 since Jun 2009
Thanks: 854 given, 7,911 received

np here mine is just Toshiba xp laptop with almost falling off screen. I use chrome set to auto update.

Reply With Quote
 
(login for full post details)
  #7 (permalink)
cusp
Bundeburg
 
 
Posts: 48 since Mar 2012
Thanks: 27 given, 49 received

I noticed this problem (finding little time loops) on the last ft71 webinar.

It didn't exist in earlier ones.
Something is different about the encoding.

Reply With Quote
 
(login for full post details)
  #8 (permalink)
 Big Mike 
Site Administrator
Swing Trader
Data Scientist & DevOps
Manta, Ecuador
 
Experience: Advanced
Platform: Custom solution
Trading: Futures & Crypto
 
Big Mike's Avatar
 
Posts: 50,014 since Jun 2009
Thanks: 32,474 given, 98,311 received

Please give me an exact webinar and exact time the problem occurs so I can take a look.

Sent from my Transformer Prime TF201 using Tapatalk 2

We're here to help -- just ask

For the best trading education, watch our webinars
Searching for trading reviews? Review this list

Follow us on Twitter, YouTube, and Facebook

Support our community as an Elite Member:
https://futures.io/elite/

Visit other sites? Please spread the word about your experience with our community!
Follow me on Twitter Visit my futures io Trade Journal Reply With Quote
 
(login for full post details)
  #9 (permalink)
 Superdoug3 
Vernon, BC, Canada
 
Experience: Beginner
Platform: Sierra Charts
Broker: Zaner Group (Transact)
Trading: ES
 
Posts: 103 since Apr 2010
Thanks: 113 given, 63 received

Since no one else has responded, I will
I must assume it has to do with my setup as I am the only complainer (well almost)
every couple of minutes the sound loops back 10 seconds or more
Also, in most cases the guest speaker seems to have an echo whereas Big Mike is always clear in the audio. I do recall in Sun Duddella's webinar others complaining about an echo too.

1 example
Sun Duddella - market Context minute at minute 21.40

I listen to lots of other webinars and futures.io (formerly BMT) is the only one I have a problem with. this started about 1 month ago

I have tried Chrome and updating Flash
currently I am using Firefox V13.o.1 which is the latest. I do have some minor issues with FF context menu but generally it serves me well
I have tried reloading my backup image from 6 months ago

I am OK with what I have, but you asked for a specific example.

Started this thread Reply With Quote
The following user says Thank You to Superdoug3 for this post:
 
(login for full post details)
  #10 (permalink)
 Big Mike 
Site Administrator
Swing Trader
Data Scientist & DevOps
Manta, Ecuador
 
Experience: Advanced
Platform: Custom solution
Trading: Futures & Crypto
 
Big Mike's Avatar
 
Posts: 50,014 since Jun 2009
Thanks: 32,474 given, 98,311 received



Superdoug3 View Post
Since no one else has responded, I will
I must assume it has to do with my setup as I am the only complainer (well almost)
every couple of minutes the sound loops back 10 seconds or more
Also, in most cases the guest speaker seems to have an echo whereas Big Mike is always clear in the audio. I do recall in Sun Duddella's webinar others complaining about an echo too.

I tested with Chrome, FireFox and IE, no problems for "sound loops back 10 seconds or more".

This is probably a connection problem, lack of bandwidth, big latency, poor network connectivity, dropped packets, or some other network problem if this happens to you randomly when watching webinars. Can you duplicate the problem at the exact minute mark in multiple browsers at different times? This would help establish if it is network or software.

As for the echo problem, this is a new development and is entirely different than what was originally reported in this thread. I am not sure if the problem is the webinar software, or hardware on my end, but when I un-mute my microphone, the other presenter echoes through my speakers. This never used to be a problem. I am looking into it and will solve it one way or another.

Mike

We're here to help -- just ask

For the best trading education, watch our webinars
Searching for trading reviews? Review this list

Follow us on Twitter, YouTube, and Facebook

Support our community as an Elite Member:
https://futures.io/elite/

Visit other sites? Please spread the word about your experience with our community!
Follow me on Twitter Visit my futures io Trade Journal Reply With Quote
 
(login for full post details)
  #11 (permalink)
 GridKing 
San Diego, CA USA
 
Experience: Intermediate
Platform: NinjaTrader
Trading: ES
 
GridKing's Avatar
 
Posts: 3,650 since May 2011
Thanks: 584 given, 881 received

with chrome I think (adobe) update is only automatic, mine updates when I restart computer which isn't frequent, there was a recent update from adobe in chrome I believe , not having issues here but have been noticing some issues with chrome last few days ....

works well latest version top right - freeware https://filehippo.com/download_ccleaner

"Successful trading is one long journey, not a destination" Peter Borish Former Head of Research for Paul Tudor Jones speaking on conversations with John F. Carter
Visit my futures io Trade Journal Reply With Quote
 
(login for full post details)
  #12 (permalink)
 Superdoug3 
Vernon, BC, Canada
 
Experience: Beginner
Platform: Sierra Charts
Broker: Zaner Group (Transact)
Trading: ES
 
Posts: 103 since Apr 2010
Thanks: 113 given, 63 received

Well I ran some tests and here is what I found out
1. When playing Big Mike Trading Webinars, I get loopbacks. I mean the video backs up about 30 seconds and replays. This happens about 50 or more times in every webinar and seems to happen more as the webinar progresses
2. Big Mike tested this on IE, Firefox and Google Chrome and did not find any loopbacks
3. Some other Big Mike subscribers also have had this, but very few
4. This does not happen to me on other webinars that I play back with Firefox
------ a. This may be because the other webinars average less than 30 minutes
5. Big Mike suggested updating Flash, this did not help
6. Big Mike requested some more research
7. Environment
------ a. I am using Windows 7 Home Premium 64 bit with 6 GB RAM
------ b. DSL with 5.7 mbps on CAT5 cable
------ c. Usually, only running MS Word 2010 at the same time
8. Research
---- a. A week ago, I quit listening to Al Brooks latest webinar at minute1:09:01 because it was almost
constant loopbacks I resumed a week later at 1:01:01 and loop backs were gone. This turned
out to be temporary
-------- i. Continue to listen to webinar on FF13 – monitor for problem
---- ii. If problem occurs in FF13 – note minute and how long it took to start looping again (elapsed time)
---------- 1. Try same webinar another webinar in Chrome – monitor for problem
---------- 2. Place an inquiry with FireFox support forum
---------- 3. Update Big Mike thread
---- iii. If problem does not occur again
------ 1. Something got fixed

results of trying different browsers on the last 2 webinars in futures.io (formerly BMT) webinars
Browser-- Webinar--------- minute started listening ----------------- Elapsed time to loop backs starting again
======--======--------- =================----------------- =============================
IE9-------- Al Brooks-------- Started
--------------------------------- 1:01 to
--------------------------------- 1:42----------------------------------------- 40 minutes
------ Market Wizards------Started
-------------------------------- 5:45 to
-------------------------------- 8:37------------------------------------------- 3 minutes
FF13 --Al Brooks------------Started
--------------------------------1:50 to
--------------------------------1:58 -------------------------------------------8 minutes
-------Market Wizards------Started
--------------------------------0 to 3:09-------------------------------------3 minutes
Chrome----Al Brooks ------Started
------------------------------1:42 to
-------------------------------1:48-------------------------------------------6 minutes
-------Market Wizards------Started
---------------------------------2:00 to
---------------------------------4:39-----------------------------------------2 minutes

As you can see
• The issue is not at a specific minute in the webinar but rather seems to build up over time
• The issue happens on each of the major browsers available to a PC
• I brought up the Window Resource Manager
------ o Network activity 100 to 800 kbps
------ o Memory use – usually 1.6 GB
------ o TCP never above 80%

Started this thread Reply With Quote
The following 2 users say Thank You to Superdoug3 for this post:
 
(login for full post details)
  #13 (permalink)
 GridKing 
San Diego, CA USA
 
Experience: Intermediate
Platform: NinjaTrader
Trading: ES
 
GridKing's Avatar
 
Posts: 3,650 since May 2011
Thanks: 584 given, 881 received

works fine for me... my suggestions

check your version Adobe - Flash Player

delete all in flash player settings


run latest version top right and clean everything Download CCleaner 3.20.1750 - FileHippo.com

in chrome try new incognito and see if same problems occur if not , it's an extension you have or something ...

"Successful trading is one long journey, not a destination" Peter Borish Former Head of Research for Paul Tudor Jones speaking on conversations with John F. Carter
Visit my futures io Trade Journal Reply With Quote
The following 2 users say Thank You to GridKing for this post:
 
(login for full post details)
  #14 (permalink)
 Big Mike 
Site Administrator
Swing Trader
Data Scientist & DevOps
Manta, Ecuador
 
Experience: Advanced
Platform: Custom solution
Trading: Futures & Crypto
 
Big Mike's Avatar
 
Posts: 50,014 since Jun 2009
Thanks: 32,474 given, 98,311 received

Doug,

If the "loop backs" are not happening at the exact same time in each video, then it sounds like a network problem (connectivity, internet, isp).

If you have a laptop that exhibits this issue, you could prove the problem by going to a friends house or Starbucks or something and using their wi-fi.

The webinars are viewed about 1,000 times a day, and you are the only one experiencing an issue. This makes it virtually impossible for me to be able to do anything, because the problem is almost 100% certainly due to your environment.

Mike

We're here to help -- just ask

For the best trading education, watch our webinars
Searching for trading reviews? Review this list

Follow us on Twitter, YouTube, and Facebook

Support our community as an Elite Member:
https://futures.io/elite/

Visit other sites? Please spread the word about your experience with our community!
Follow me on Twitter Visit my futures io Trade Journal Reply With Quote
The following user says Thank You to Big Mike for this post:
 
(login for full post details)
  #15 (permalink)
 marty001 
los angeles
 
Experience: Advanced
Platform: sc
Trading: dax
 
Posts: 11 since Mar 2012
Thanks: 54 given, 0 received

I play the webinars with a Vista machine, google chrome, and did not know what the repeat problem was, I assumed it was just me, or revisions of some sort. I am glad to know there is a label for this, my ignorance. Thanks Superdoug, BigMike and others for definitions and cures.

Reply With Quote
 
(login for full post details)
  #16 (permalink)
 josh 
Legendary Market Wizard
Georgia, US
 
Experience: None
Platform: SC
Broker: AMP+CQG
Trading: ES, HSI, Nikkei
 
josh's Avatar
 
Posts: 5,466 since Jan 2011
Thanks: 6,055 given, 14,517 received

Ever since watching webinars from the futures.io (formerly BMT) site (not from youtube), I have also had this skipping problem. It happens when the player is paused for a few minutes. When play is clicked, it starts, and then will skip back about 30 seconds or so. I would have reported this earlier had I thought anyone else had the problem. I am running Chrome on Win7. It's not the most annoying thing in the world, but it does make me hesitant to press pause when watching if I have to go do something

Reply With Quote
 
(login for full post details)
  #17 (permalink)
 Tarkus11 
East Coast
 
Experience: Beginner
Platform: Ninja
Trading: ES, NQ
 
Posts: 126 since Apr 2010
Thanks: 55 given, 80 received

I just tried this and have no problem with Win7/Chrome. Chrome runs multiple instances of itself as "sandbox" security, but I do not see much resource usage in Task Manager while running it.

I am running on a SSD, so there wouldn't be any buffer issues, and I dedicate 3 of my cores (even though it uses only 1 of them) to NT using the Affinity command, so anything else has to run on another core.

Reply With Quote
 
(login for full post details)
  #18 (permalink)
 Big Mike 
Site Administrator
Swing Trader
Data Scientist & DevOps
Manta, Ecuador
 
Experience: Advanced
Platform: Custom solution
Trading: Futures & Crypto
 
Big Mike's Avatar
 
Posts: 50,014 since Jun 2009
Thanks: 32,474 given, 98,311 received


josh View Post
Ever since watching webinars from the futures.io (formerly BMT) site (not from youtube), I have also had this skipping problem. It happens when the player is paused for a few minutes. When play is clicked, it starts, and then will skip back about 30 seconds or so. I would have reported this earlier had I thought anyone else had the problem. I am running Chrome on Win7. It's not the most annoying thing in the world, but it does make me hesitant to press pause when watching if I have to go do something

Please give me an exact webinar (or URL) and an exact time where you paused it and how long you waited before resuming, so I can try to reproduce.

Mike

We're here to help -- just ask

For the best trading education, watch our webinars
Searching for trading reviews? Review this list

Follow us on Twitter, YouTube, and Facebook

Support our community as an Elite Member:
https://futures.io/elite/

Visit other sites? Please spread the word about your experience with our community!
Follow me on Twitter Visit my futures io Trade Journal Reply With Quote
 
(login for full post details)
  #19 (permalink)
 josh 
Legendary Market Wizard
Georgia, US
 
Experience: None
Platform: SC
Broker: AMP+CQG
Trading: ES, HSI, Nikkei
 
josh's Avatar
 
Posts: 5,466 since Jan 2011
Thanks: 6,055 given, 14,517 received


Tarkus11 View Post
I dedicate 3 of my cores (even though it uses only 1 of them) to NT using the Affinity command, so anything else has to run on another core.

This is a little off-topic, sorry, but:

I see how to set the affinity for a single process, but how do you actually prevent all new spawned processes from using certain cores? From what I can see, they are all enabled by default.

Have you found any advantage to simply setting the process priority higher?

Reply With Quote
 
(login for full post details)
  #20 (permalink)
 Big Mike 
Site Administrator
Swing Trader
Data Scientist & DevOps
Manta, Ecuador
 
Experience: Advanced
Platform: Custom solution
Trading: Futures & Crypto
 
Big Mike's Avatar
 
Posts: 50,014 since Jun 2009
Thanks: 32,474 given, 98,311 received

I was able to reproduce the skipping problem today.

I do not have a fix. Eventually I am forced to move to HTML5 and away from Flash, but the migration is an enormous undertaking because I have to re-encode all videos and work on anti-piracy measures. May be a while.

Mike

We're here to help -- just ask

For the best trading education, watch our webinars
Searching for trading reviews? Review this list

Follow us on Twitter, YouTube, and Facebook

Support our community as an Elite Member:
https://futures.io/elite/

Visit other sites? Please spread the word about your experience with our community!
Follow me on Twitter Visit my futures io Trade Journal Reply With Quote
The following user says Thank You to Big Mike for this post:
 
(login for full post details)
  #21 (permalink)
 Superdoug3 
Vernon, BC, Canada
 
Experience: Beginner
Platform: Sierra Charts
Broker: Zaner Group (Transact)
Trading: ES
 
Posts: 103 since Apr 2010
Thanks: 113 given, 63 received

thank you for the update. I had heard from someone else with this skipping problem, so I knew that I was not alone. Your fix is low priority for me

Started this thread Reply With Quote
 
(login for full post details)
  #22 (permalink)
 V i m 
Northern Indiana, USA
 
Experience: Beginner
Platform: NinjaTrader
Broker: Mirus/Zen-Fire
Trading: M6E, 6E
 
V i m's Avatar
 
Posts: 137 since Oct 2012
Thanks: 87 given, 65 received

I also have this issue, just so you have some more feedback from other users. It always occurs for me after I pause it. It's not that big of a deal, but at some point after the pause I usually have to listen to a loop back of the audio for maybe 15-30 seconds. And honestly, it's probably better that I hear it again anyway - that way it sinks in.

I don't recall it ever affecting the video of the slides though, but I haven't paid that close of attention to it.

Pecunia, si uti scis, ancilla est; si nescis, domina. Faber est suae quisque fortunae.
Visit my futures io Trade Journal Reply With Quote
 
(login for full post details)
  #23 (permalink)
 Big Mike 
Site Administrator
Swing Trader
Data Scientist & DevOps
Manta, Ecuador
 
Experience: Advanced
Platform: Custom solution
Trading: Futures & Crypto
 
Big Mike's Avatar
 
Posts: 50,014 since Jun 2009
Thanks: 32,474 given, 98,311 received


V i m View Post
I also have this issue, just so you have some more feedback from other users. It always occurs for me after I pause it. It's not that big of a deal, but at some point after the pause I usually have to listen to a loop back of the audio for maybe 15-30 seconds. And honestly, it's probably better that I hear it again anyway - that way it sinks in.

I don't recall it ever affecting the video of the slides though, but I haven't paid that close of attention to it.

Will eventually be fixed when I role out the HTML5 videos. No firm ETA on that yet other than "this year".

Mike

We're here to help -- just ask

For the best trading education, watch our webinars
Searching for trading reviews? Review this list

Follow us on Twitter, YouTube, and Facebook

Support our community as an Elite Member:
https://futures.io/elite/

Visit other sites? Please spread the word about your experience with our community!
Follow me on Twitter Visit my futures io Trade Journal Reply With Quote
The following user says Thank You to Big Mike for this post:
 
(login for full post details)
  #24 (permalink)
 V i m 
Northern Indiana, USA
 
Experience: Beginner
Platform: NinjaTrader
Broker: Mirus/Zen-Fire
Trading: M6E, 6E
 
V i m's Avatar
 
Posts: 137 since Oct 2012
Thanks: 87 given, 65 received


Big Mike View Post
Will eventually be fixed when I role out the HTML5 videos. No firm ETA on that yet other than "this year".

Mike

Thanks Mike.

Hopefully you don't have to do any extra work to fix the issue other than the new roll outs anyway? Because I doubt those of us having the issue would consider it that important. And there are probably better things you would want to spend your time on - perhaps one of them being a vacation!

While I have you here, I would like to express my gratitude to you for running this site. I know it must be a tremendous amount of work. But without your site, I highly doubt I would have even been able to get started trading without falling prey to all the negativity and misinformation out there. So thank you.

Pecunia, si uti scis, ancilla est; si nescis, domina. Faber est suae quisque fortunae.
Visit my futures io Trade Journal Reply With Quote
The following user says Thank You to V i m for this post:
 
(login for full post details)
  #25 (permalink)
 Big Mike 
Site Administrator
Swing Trader
Data Scientist & DevOps
Manta, Ecuador
 
Experience: Advanced
Platform: Custom solution
Trading: Futures & Crypto
 
Big Mike's Avatar
 
Posts: 50,014 since Jun 2009
Thanks: 32,474 given, 98,311 received

Search for a thread called month long vacation to see my plans.

Search for html5 to see details on the webinars thread

Sent from my Nexus 4

We're here to help -- just ask

For the best trading education, watch our webinars
Searching for trading reviews? Review this list

Follow us on Twitter, YouTube, and Facebook

Support our community as an Elite Member:
https://futures.io/elite/

Visit other sites? Please spread the word about your experience with our community!
Follow me on Twitter Visit my futures io Trade Journal Reply With Quote


futures io Trading Community Off-Topic Tech Support > experiencing a tech problem with replay of bmt webinars


Last Updated on February 26, 2013


Upcoming Webinars and Events
 

NinjaTrader Indicator Challenge!

Ongoing
 

Journal Challenge w/$1,800 in prizes!

April

An Introduction to CME Group Micro Bitcoin Futures w/David Lerman

Elite only
     



Copyright © 2021 by futures io, s.a., Av Ricardo J. Alfaro, Century Tower, Panama, Ph: +507 833-9432 (Panama and Intl), +1 888-312-3001 (USA and Canada), info@futures.io
All information is for educational use only and is not investment advice.
There is a substantial risk of loss in trading commodity futures, stocks, options and foreign exchange products. Past performance is not indicative of future results.
no new posts