Simulation Mode - futures io
futures io futures trading



Simulation Mode


Discussion in Platforms and Indicators

Updated by TradingTech
      Top Posters
    1. looks_one met68 with 9 posts (1 thanks)
    2. looks_two SMCJB with 5 posts (0 thanks)
    3. looks_3 BTR411 with 1 posts (0 thanks)
    4. looks_4 TradingTech with 1 posts (0 thanks)
    1. trending_up 4,693 views
    2. thumb_up 1 thanks given
    3. group 7 followers
    1. forum 17 replies
    2. attach_file 2 attachments




Welcome to futures io: the largest futures trading community on the planet, with well over 100,000 members
  • Genuine reviews from real traders, not fake reviews from stealth vendors
  • Quality education from leading professional traders
  • We are a friendly, helpful, and positive community
  • We do not tolerate rude behavior, trolling, or vendors advertising in posts
  • We are here to help, just let us know what you need
You'll need to register in order to view the content of the threads and start contributing to our community.  It's free and simple.

-- Big Mike, Site Administrator

(If you already have an account, login at the top of the page)

 
Search this Thread
 

Simulation Mode

(login for full post details)
  #1 (permalink)
Ragusa Italy
 
 
Posts: 50 since Jan 2014
Thanks: 6 given, 24 received

So after all my previous woes with X_Trader Pro (see my previous thread re Windows BFE Service), I did actually get this to work, sort of.

I have even set-up my one of my live accounts at AMP with X_Trader Pro and am trying to further test this s/w in Simulation mode. Unfortunately, I am finding, that pretty much nothing works as it is meant to in SIM mode.

Am I the only person in the world trying to work with X_Trader Pro in SIM mode?

Because it kind of feels like that, as I am having new problems and issues on a daily basis with this and I keep spending between 1h-2h PER DAY for the last week with TT tech support, but with no results to date.

First, I am finding that the P&L no longer works in SIM mode. I was just getting n/a in the position windows, whenever I would place a trade. So, on to TT tech support, who "solve" the issue (only for it to return, after I re-launch X_Trader). And as part of the "fix" for the broken P&L, now the CME product server is suddenly no longer available (still in SIM mode). After a further day on the phone with TT tech support, they realise that they can easily recreate the problem and it gets escalated. Today it seems to kind of work. Some CME products are available, others are not....

Then, I am finding that X_Study charts on my workspaces no longer open. Then, about an hour later, suddenly X_Study charts do open again, but now without any historical data.

So back onto the phone with TT tech support, where I am being told that they are aware of this issue and that engineers are working on it, but no ETA on when this might be fixed.

Seriously, people pay $1'500 PER MONTH for this garbage?

I am truly amazed, with what some people get away with.....

And how any prospective new customers are meant to feel confident to switch from SIM to LIVE mode, when clearly nothing works is also beyond me.

I really wanted to like this s/w, as I have recently started trading spreads and the X_Trader Pro Autospreader would be pretty neat. But trying as I might, this s/w just does not work (in SIM mode). I am certainly not going to try in LIVE mode, until I feel comfortable, that this platform actually works in SIM mode.

I may try it again in a few months, but for now, once again, I am left deeply disappointed with this overrated and overpriced platform.

Now looking for an other platform to trade spreads. Any recommendations would be welcome.

Reply With Quote
The following user says Thank You to met68 for this post:

 
Best Threads (Most Thanked)
in the last 7 days on futures io
Is anyone actually making money?
184 thanks
Micro account vs Funded account (combine)
52 thanks
Are sharks watching on the other side?
32 thanks
Market profile entries/exits
25 thanks
Spoo-nalysis ES e-mini futures S&P 500
22 thanks
 
(login for full post details)
  #2 (permalink)
Ragusa Italy
 
 
Posts: 50 since Jan 2014
Thanks: 6 given, 24 received

It just never stops. And so the X_Trader Pro saga continues. Now, when I try and open a hourly chart for a spread of two CME contracts (still in SIM mode), all data between March 5th and today is simply missing. Brilliant for backtesting.....

So back on the phone to TT tech support. And apparently they are aware of this issue also and working on it also.....

Frankly, they might be best off to just bin the entire X_Trader SIM module, as I have not been able to use it for two days in a row without running into significant issues, which mean that each time, I am unable to do what I was planning to do. Clearly not a workable way forward.

Anybody considering X_Trader Pro and intending to make use of the Simulation mode; don't! Find an other platform.

Reply With Quote
 
(login for full post details)
  #3 (permalink)
Legendary Market Wizard
Houston, TX
 
Experience: Advanced
Platform: XTrader and Cloud TT
Broker: Advantage Futures
Trading: Energy
 
Posts: 3,490 since Dec 2013
Thanks: 2,782 given, 6,563 received


I agree that when you are paying this amount of money for software you expect it to work.

As you probably know though, people don't get XTrader for it's charting abilities. TT's sim was only recently released and I believe was designed with testing ADL Algo's in mind. My advice would be to not use XStudy in sim, but to just use sim to test XTrader's automated trading tools, ADL, Autospreader and Autotrader. If you do that i think you will find it is an excellent simulation/testing tool.

Reply With Quote
 
(login for full post details)
  #4 (permalink)
Ragusa Italy
 
 
Posts: 50 since Jan 2014
Thanks: 6 given, 24 received

@ scjmb,

I am not even that fussed about X_Study, but how can I test algos and spreads, when none of the P&L's work, when large chunks of data are missing and when the necessary price and fill API servers are down half the time?

Today, when I started X_Trader Pro again, now more out of curiosity, I found that the price and API fill servers were down and hence X_Trader did not start at all.

I will continue to open this useless platform once a day, merely to find-out what will go wrong that day. Kind of entertaining, in a farcical way.

Reply With Quote
 
(login for full post details)
  #5 (permalink)
Legendary Market Wizard
Houston, TX
 
Experience: Advanced
Platform: XTrader and Cloud TT
Broker: Advantage Futures
Trading: Energy
 
Posts: 3,490 since Dec 2013
Thanks: 2,782 given, 6,563 received


met68 View Post
how can I test algos and spreads, when none of the P&L's work

Not sure what you mean by this. I never use the P&L's in sim because a lot of the times I am trading against myself/simulating trading situations so my position isnt what it would be in real life. I will check next time I am in sim though.


met68 View Post
when large chunks of data are missing

I assume you realize that TT sim is used for pricing against live date and not historical/recorded data. Hence there shouldn't be any data "missing" for any products you are trading. If there are problems with certain products not having pricing data that's probably the way the gateways are set up ... which is on your broker.


met68 View Post
the necessary price and fill API servers are down half the time?

I think that is a broker/gateway issue not software issue.


met68 View Post
Today, when I started X_Trader Pro again, now more out of curiosity, I found that the price and API fill servers were down and hence X_Trader did not start at all.

I think that is a broker/gateway issue not software issue.


met68 View Post
I will continue to open this useless platform once a day, merely to find-out what will go wrong that day. Kind of entertaining, in a farcical way.

If your broker doesn't have you configured on the Gateways correctly it will never work...

Don't get me wrong, sim is very quirky, and there are issues, but I think most of what you listed here today are probably not software issues but gateway and or setup issues which are most likely your brokers fault.

Reply With Quote
 
(login for full post details)
  #6 (permalink)
Ragusa Italy
 
 
Posts: 50 since Jan 2014
Thanks: 6 given, 24 received


SMCJB View Post
Not sure what you mean by this. I never use the P&L's in sim because a lot of the times I am trading against myself/simulating trading situations so my position isnt what it would be in real life.

Not sure what you mean, but when I want to test algos, spreads or any trading strategy, I want to know at all time, what my current position p&l is. X_Trader in SIM mode simply shows me "N/A". TT have attempted to fix this, but without success. Not helpful.


SMCJB View Post
I assume you realize that TT sim is used for pricing against live date and not historical/recorded data. Hence there shouldn't be any data "missing" for any products you are trading. If there are problems with certain products not having pricing data that's probably the way the gateways are set up ... which is on your broker.

Do you have any affiliations with TT? Anyway, one day recently there were issues with Eurex data, which was simply unavailable (live and historic). Then Eurex data was suddenly back, but with gaping holes in it. Then CME servers were down, then they were up again. I don't care whether it is TT or my broker. TT were aware of these issues and never suggested that it was a broker/ gateway issue. Instead they said they knew there were problems and that their engineers were working on it.


SMCJB View Post
If your broker doesn't have you configured on the Gateways correctly it will never work...

My broker and TT have spent hours in remote sessions attempting to set-up my X_Trader instance to work properly in SIM mode. Without success. Remember, as far as I can tell, everything works fine in live mode. Again, these issues all relate to the SIM mode. And without a working SIM mode, this platform is of absolutely no use to me.


SMCJB View Post
Don't get me wrong, sim is very quirky, and there are issues, but I think most of what you listed here today are probably not software issues but gateway and or setup issues which are most likely your brokers fault.

No, they are not.

Reply With Quote
 
(login for full post details)
  #7 (permalink)
Ragusa Italy
 
 
Posts: 50 since Jan 2014
Thanks: 6 given, 24 received

And the saga continues, when I started X_Trader in SIM mode this morning, this is what greeted me:


Reply With Quote
 
(login for full post details)
  #8 (permalink)
Ragusa Italy
 
 
Posts: 50 since Jan 2014
Thanks: 6 given, 24 received

And now, as if by magic, X_Trader opens up ok, BUT (drum-roll......) ...... none of the Eurex charts are updating (haven't tried other exchanges).......

Oh my, this is a bag of fun.....

Reply With Quote
 
(login for full post details)
  #9 (permalink)
Ragusa Italy
 
 
Posts: 50 since Jan 2014
Thanks: 6 given, 24 received

Ah, and did I mention, that the FDAX T&S is simply showing an endless stream of 24 sized OTC trades. Not a single non-OTC trade showing. Ah well, TT never fail to come-up with ever more completely unexpected screw-up's.....

Reply With Quote
 
(login for full post details)
  #10 (permalink)
Legendary Market Wizard
Houston, TX
 
Experience: Advanced
Platform: XTrader and Cloud TT
Broker: Advantage Futures
Trading: Energy
 
Posts: 3,490 since Dec 2013
Thanks: 2,782 given, 6,563 received



met68 View Post
Do you have any affiliations with TT?

Just a user for over 10 years, who has multiple XTrader Pro licenses including a box dedicated to running sim.


I could go through and try and address every point but I don't want to get into any more of a mud slinging match.

Like you, the few experiences I have with XStudy (live not sim) are bad - due to bad data. In every case it was 100% the fault of the broker (in this case GS) and their FMDS server. It sounds like many of the problems here are related to XStudy and your brokers FMDS server and not the sim software itself. Does your XStudy work in the live environment?

Sim is a little quirky and I have found sometimes it needs to be shutdown and reopened more than it should. The broker I use (Advantage Futures) have a special dedicated simulation environment so that it doesn't interfere with their production environment. Advantage actually charge extra for you to use/connect to sim because of he extra work involved. I also have a box dedicated to running sim, so that I don't have the issues of stopping/restarting sim. The combination of the two means my sim does work and is extremely reliable. FYI Advantage also charge extra for XStudy because of the extra work involved in maintaining FMDS - while I don't use XStudy I understand their XStudy is also very reliable. (Yes I'm a big fan of Advantage as well as XTrader!).

I have to ask does your broker have other users using sim or are they learning along with you? I have checked and I have correct P&Ls so that's not a flaw in the software that effects everybody.

As I said once before I agree that when you are paying this amount of money for software all aspects of it should work. As you probably know though, people don't get XTrader for it's charting abilities. TT's sim was only recently released and I believe was designed with testing ADL Algo's in mind. My advice would be to not use XStudy in sim, but to just use sim to test XTrader's automated trading tools. If you do that i think you will find it is an excellent simulation/testing tool.


P&L...

Reply With Quote


futures io Trading Community Platforms and Indicators > Simulation Mode


February 26, 2016


Upcoming Webinars and Events
 

Every journal equals ten meals for the hungry

Now
     



Copyright © 2020 by futures io, s.a., Av Ricardo J. Alfaro, Century Tower, Panama, +507 833-9432, info@futures.io
All information is for educational use only and is not investment advice.
There is a substantial risk of loss in trading commodity futures, stocks, options and foreign exchange products. Past performance is not indicative of future results.
no new posts