Interactive Brokers gateway losing connectivity - futures io
futures io futures trading



Interactive Brokers gateway losing connectivity


Discussion in Platforms and Indicators

Updated by NGtrader
      Top Posters
    1. looks_one Fadi with 9 posts (9 thanks)
    2. looks_two michaelf with 6 posts (1 thanks)
    3. looks_3 NGtrader with 4 posts (1 thanks)
    4. looks_4 Ming80 with 3 posts (1 thanks)
      Best Posters
    1. looks_one moses with 2.0 thanks per post
    2. looks_two Big Mike with 1.7 thanks per post
    3. looks_3 Fadi with 1.0 thanks per post
    4. looks_4 michaelf with 0.2 thanks per post
    1. trending_up 18,641 views
    2. thumb_up 21 thanks given
    3. group 13 followers
    1. forum 34 replies
    2. attach_file 6 attachments




Welcome to futures io: the largest futures trading community on the planet, with well over 100,000 members
  • Genuine reviews from real traders, not fake reviews from stealth vendors
  • Quality education from leading professional traders
  • We are a friendly, helpful, and positive community
  • We do not tolerate rude behavior, trolling, or vendors advertising in posts
  • We are here to help, just let us know what you need
You'll need to register in order to view the content of the threads and start contributing to our community.  It's free and simple.

-- Big Mike, Site Administrator

(If you already have an account, login at the top of the page)

 
Thread Tools Search this Thread
 

Interactive Brokers gateway losing connectivity

  #21 (permalink)
Mérida, Mexico
 
Experience: Intermediate
Platform: NinjaTrader 8
Broker: NinjaTrader Brokerage
Trading: CL
 
michaelf's Avatar
 
Posts: 520 since Mar 2011
Thanks: 1,286 given, 542 received


Fadi View Post
It is a configuration thing sometimes not that obvious I admit.

If you want to share a screen shot of your IB connection configuration in NT7 and another snapshot of your Gateway settings then I can troubleshoot you on the spot.

Cheers
F

Hi @Fadi

Here we go,

First I start Gateway, then I start NT7, when I want to connect the two, an new IB login appears, when I login again it ask me to to close the first session.

Also I think my Gateway does not have a market data connection.

Thats it. Here a few screenshots, hope you can help.

thanks michael

Attached Thumbnails
Click image for larger version

Name:	IB.JPG
Views:	71
Size:	44.4 KB
ID:	133180   Click image for larger version

Name:	NT7.JPG
Views:	67
Size:	40.7 KB
ID:	133181   Click image for larger version

Name:	IB2.JPG
Views:	43
Size:	19.9 KB
ID:	133182  
Follow me on Twitter Visit my futures io Trade Journal Reply With Quote

Can you help answer these questions
from other members on futures io?
Convert NinjaTrader NT7 indicator to Tradestation EasyLanguage and RADARSCREEN
Platforms and Indicators
Issue meeting order entry conditions
Elite Automated NinjaTrader Trading
Last 5 minutes Label
ThinkOrSwim
Moving average with Lag reduction
NinjaTrader
Linux?
ThinkOrSwim
 
 
  #22 (permalink)
Luxembourg
 
Experience: Advanced
Platform: NinjaTrader
Broker: IB / Kinetick
Trading: ES, CL
 
Fadi's Avatar
 
Posts: 485 since Apr 2012
Thanks: 663 given, 643 received


michaelf View Post
Hi @Fadi

Here we go,

First I start Gateway, then I start NT7, when I want to connect the two, an new IB login appears, when I login again it ask me to to close the first session.

Also I think my Gateway does not have a market data connection.

Thats it. Here a few screenshots, hope you can help.

thanks michael

Hi Michael
Try to put your computer's IP address in the HOST field (instead of 127.0.01)
Also, in the gateway setup window, add that same computer's IP address to the list of trusted IP's.

Continue to connect to the gateway first, and then connect NT7 to it.
You shouldn't see a new IB login window popping up anymore...

Successful people will do what unsuccessful people won't or can't do!
Follow me on Twitter Visit my Facebook Reply With Quote
The following user says Thank You to Fadi for this post:
 
  #23 (permalink)
Mérida, Mexico
 
Experience: Intermediate
Platform: NinjaTrader 8
Broker: NinjaTrader Brokerage
Trading: CL
 
michaelf's Avatar
 
Posts: 520 since Mar 2011
Thanks: 1,286 given, 542 received



Fadi View Post
Hi Michael
Try to put your computer's IP address in the HOST field (instead of 127.0.01)
Also, in the gateway setup window, add that same computer's IP address to the list of trusted IP's.

Continue to connect to the gateway first, and then connect NT7 to it.
You shouldn't see a new IB login window popping up anymore...

@Fadi

Now I have message from NT: Login faild:IB Adapter. MessageLoop. Host is not known

Follow me on Twitter Visit my futures io Trade Journal Reply With Quote
 
  #24 (permalink)
Luxembourg
 
Experience: Advanced
Platform: NinjaTrader
Broker: IB / Kinetick
Trading: ES, CL
 
Fadi's Avatar
 
Posts: 485 since Apr 2012
Thanks: 663 given, 643 received


michaelf View Post
@Fadi

Now I have message from NT: Login faild:IB Adapter. MessageLoop. Host is not known

did you put your username and password in the NT7 connection setup window, and checked the auto logon?
At least this is how I do it personally, I don't get to enter the username and password each time I connect...

Successful people will do what unsuccessful people won't or can't do!
Follow me on Twitter Visit my Facebook Reply With Quote
The following user says Thank You to Fadi for this post:
 
  #25 (permalink)
Mérida, Mexico
 
Experience: Intermediate
Platform: NinjaTrader 8
Broker: NinjaTrader Brokerage
Trading: CL
 
michaelf's Avatar
 
Posts: 520 since Mar 2011
Thanks: 1,286 given, 542 received


Fadi View Post
did you put your username and password in the NT7 connection setup window, and checked the auto logon?
At least this is how I do it personally, I don't get to enter the username and password each time I connect...

Yes I tried, I know it is not easy to setup the connection. Also I saw a video on youtube how to connect, put unfortunately the instruction are not complete.

So I will wait until NT8 comes out and hope they had changed something.

thanks
michael

Follow me on Twitter Visit my futures io Trade Journal Reply With Quote
 
  #26 (permalink)
Luxembourg
 
Experience: Advanced
Platform: NinjaTrader
Broker: IB / Kinetick
Trading: ES, CL
 
Fadi's Avatar
 
Posts: 485 since Apr 2012
Thanks: 663 given, 643 received


michaelf View Post
Yes I tried, I know it is not easy to setup the connection. Also I saw a video on youtube how to connect, put unfortunately the instruction are not complete.

So I will wait until NT8 comes out and hope they had changed something.

thanks
michael

Strange, it works for me perfectly...

The thing is that I do have virtual machines running on my computer, and in one of them I have NT7 and in another one I have the IB Gateway or TWS.
So basically, I have different IP addresses for each machine, perhaps that's why it is working. Dunno...

Successful people will do what unsuccessful people won't or can't do!
Follow me on Twitter Visit my Facebook Reply With Quote
The following user says Thank You to Fadi for this post:
 
  #27 (permalink)
Luxembourg
 
Experience: Advanced
Platform: NinjaTrader
Broker: IB / Kinetick
Trading: ES, CL
 
Fadi's Avatar
 
Posts: 485 since Apr 2012
Thanks: 663 given, 643 received

These are snapshots of my current configuration that works.




Successful people will do what unsuccessful people won't or can't do!
Follow me on Twitter Visit my Facebook Reply With Quote
The following user says Thank You to Fadi for this post:
 
  #28 (permalink)
Mérida, Mexico
 
Experience: Intermediate
Platform: NinjaTrader 8
Broker: NinjaTrader Brokerage
Trading: CL
 
michaelf's Avatar
 
Posts: 520 since Mar 2011
Thanks: 1,286 given, 542 received

The last 2 days I tried everything to connect NT7 with IB Gateway without success.
But finaly I got all together and its working fine and stable on my Windows 7 without virtual machine.

How I did it: I downloaded a free small programm called TWSStart from here
Private Homepage for TWSStart

and I adjusted it exactly like in this Youtube video
Connect NinjaTrader 7 with IB-Gateway - YouTube

There are other videos, also from the autor, but for me only the above one worked out.

I hope it helps somebody else.

michael

Follow me on Twitter Visit my futures io Trade Journal Reply With Quote
The following user says Thank You to michaelf for this post:
 
  #29 (permalink)
San Antonio
 
Experience: Advanced
Platform: NinjaTrader Interactive Brokers
Broker: Interactive Brokers
Trading: forex
 
Posts: 45 since Oct 2010
Thanks: 0 given, 116 received

Old Post With Good Info

I struggled with this in the past. I figured it out and use it everyday. Try this old post if you still don't have it.


Visit my futures io Trade Journal Reply With Quote
 
  #30 (permalink)
Vancouver, Canada
 
Experience: Intermediate
Platform: Ninjatrader, Sierra Chart
Broker: Ninjatrader Continuum
Trading: ES, ZB
 
Posts: 180 since Apr 2014
Thanks: 634 given, 136 received


Sorry about resurrecting an old thread. My friend and I are running an automated strategy using NT8 and IB gateway version 9.60 (we were informed by NT support that this was the most stable one to use with NT8) and we have had to do manual log-in after disconnections no matter what version we used.


My friend has been on the phone with IB API dept constantly and it's aggravating as hell as you can imagine. Do the 3rd party solutions such as IBcontroller and TWSstart also work with NT8 or are they just for NT7?

Follow me on Twitter Reply With Quote



futures io Trading Community Platforms and Indicators > Interactive Brokers gateway losing connectivity




Upcoming Webinars and Events
 

Free BloodHound Licenses to everyone!

June
 

Every journal equals ten meals for the hungry

June
     



Copyright © 2020 by futures io, s.a., Av Ricardo J. Alfaro, Century Tower, Panama, +507 833-9432, info@futures.io
All information is for educational use only and is not investment advice.
There is a substantial risk of loss in trading commodity futures, stocks, options and foreign exchange products. Past performance is not indicative of future results.
no new posts