IB Gateway stuck on "Initializing environment" - futures io
futures io futures trading



IB Gateway stuck on "Initializing environment"


Discussion in Platforms and Indicators

Updated by Big Mike
    1. trending_up 2,561 views
    2. thumb_up 2 thanks given
    3. group 1 followers
    1. forum 7 replies
    2. attach_file 0 attachments




Welcome to futures io: the largest futures trading community on the planet, with well over 100,000 members
  • Genuine reviews from real traders, not fake reviews from stealth vendors
  • Quality education from leading professional traders
  • We are a friendly, helpful, and positive community
  • We do not tolerate rude behavior, trolling, or vendors advertising in posts
  • We are here to help, just let us know what you need
You'll need to register in order to view the content of the threads and start contributing to our community.  It's free and simple.

-- Big Mike, Site Administrator

(If you already have an account, login at the top of the page)

 
Thread Tools Search this Thread
 

IB Gateway stuck on "Initializing environment"

  #1 (permalink)
Site Administrator
Manta, Ecuador
 
Experience: Advanced
Platform: My own custom solution
Trading: Emini Futures
 
Big Mike's Avatar
 
Posts: 48,774 since Jun 2009
Thanks: 31,485 given, 94,155 received

IB Gateway stuck on "Initializing environment"



TWS updated to a new build and now I can't get IB Gateway to load. It just hangs on "Initializing environment" every time. Build 931.2.

I'm going to try a few things, but hoping someone else knows of a quick fix...

Mike

We're here to help -- just ask

For the best trading education, watch our webinars
Searching for trading reviews? Review this list

Follow us on Twitter, YouTube, and Facebook

Support our community as an Elite Member:
https://futures.io/elite/
Follow me on Twitter Visit my Facebook Visit my futures io Trade Journal Reply With Quote

Can you help answer these questions
from other members on futures io?
Convert NinjaTrader NT7 indicator to Tradestation EasyLanguage and RADARSCREEN
Platforms and Indicators
Issue meeting order entry conditions
Elite Automated NinjaTrader Trading
Last 5 minutes Label
ThinkOrSwim
Moving average with Lag reduction
NinjaTrader
Linux?
ThinkOrSwim
 
 
  #2 (permalink)
Thessaloniki, Greece
 
Experience: Beginner
Platform: QTS
Broker: IB
Trading: Equities, NQ
 
Posts: 165 since May 2012
Thanks: 104 given, 389 received

I was going to post about this, getting the same problem. Tried re-installing at a different location, turning off the firewall, etc...nothing helped.

Here's the log:

 
Code
ED 03:02:36:388 AWT-EventQueue-0: Error


ED 03:02:45:795 JTS-CCPPing-21: Warning: not received heartbeat at 11000 elapsed:11000
ED 03:02:46:795 JTS-CCPPing-21: Warning: not received heartbeat at 12000 elapsed:12000
ED 03:02:47:795 JTS-CCPPing-21: Warning: not received heartbeat at 13000 elapsed:13000
ED 03:02:48:795 JTS-CCPPing-21: Warning: not received heartbeat at 14000 elapsed:14000
ED 03:02:49:795 JTS-CCPPing-21: Warning: sending test request at 15000
ED 03:02:49:958 JTS-LogonDispatcher-20: Received heartbeat

Follow me on Twitter Reply With Quote
 
  #3 (permalink)
Site Administrator
Manta, Ecuador
 
Experience: Advanced
Platform: My own custom solution
Trading: Emini Futures
 
Big Mike's Avatar
 
Posts: 48,774 since Jun 2009
Thanks: 31,485 given, 94,155 received


TWS loads fine. IB Gateway still won't load, even after TWS started fine.

Mike

We're here to help -- just ask

For the best trading education, watch our webinars
Searching for trading reviews? Review this list

Follow us on Twitter, YouTube, and Facebook

Support our community as an Elite Member:
https://futures.io/elite/
Follow me on Twitter Visit my Facebook Visit my futures io Trade Journal Reply With Quote
 
  #4 (permalink)
Site Administrator
Manta, Ecuador
 
Experience: Advanced
Platform: My own custom solution
Trading: Emini Futures
 
Big Mike's Avatar
 
Posts: 48,774 since Jun 2009
Thanks: 31,485 given, 94,155 received


imPairsonator View Post
I was going to post about this, getting the same problem. Tried re-installing at a different location, turning off the firewall, etc...nothing helped.

Here's the log:

 
Code
ED 03:02:36:388 AWT-EventQueue-0: Error


ED 03:02:45:795 JTS-CCPPing-21: Warning: not received heartbeat at 11000 elapsed:11000
ED 03:02:46:795 JTS-CCPPing-21: Warning: not received heartbeat at 12000 elapsed:12000
ED 03:02:47:795 JTS-CCPPing-21: Warning: not received heartbeat at 13000 elapsed:13000
ED 03:02:48:795 JTS-CCPPing-21: Warning: not received heartbeat at 14000 elapsed:14000
ED 03:02:49:795 JTS-CCPPing-21: Warning: sending test request at 15000
ED 03:02:49:958 JTS-LogonDispatcher-20: Received heartbeat

OK thanks, maybe it is some sort of IB error then since it is happening to both of us same time. Their status page doesn't indicate any problem, but that is worthless because I've had connections be 'red' before and their status page show everything great.

I'll give it a couple hours...

Mike

We're here to help -- just ask

For the best trading education, watch our webinars
Searching for trading reviews? Review this list

Follow us on Twitter, YouTube, and Facebook

Support our community as an Elite Member:
https://futures.io/elite/
Follow me on Twitter Visit my Facebook Visit my futures io Trade Journal Reply With Quote
The following user says Thank You to Big Mike for this post:
 
  #5 (permalink)
Site Administrator
Manta, Ecuador
 
Experience: Advanced
Platform: My own custom solution
Trading: Emini Futures
 
Big Mike's Avatar
 
Posts: 48,774 since Jun 2009
Thanks: 31,485 given, 94,155 received

Tried a few hours later, still same problem.

Mike

We're here to help -- just ask

For the best trading education, watch our webinars
Searching for trading reviews? Review this list

Follow us on Twitter, YouTube, and Facebook

Support our community as an Elite Member:
https://futures.io/elite/
Follow me on Twitter Visit my Facebook Visit my futures io Trade Journal Reply With Quote
 
  #6 (permalink)
Oberhausen, Germany
 
Experience: Advanced
Platform: Sierracharts
Broker: Interactive Brokers/DTN IQFeed
Trading: Bund Future
 
Posts: 278 since Aug 2011
Thanks: 100 given, 311 received

I use the standard TWS: no problem. Tried the gateway just for fun and get the same result as you: hangs on initialization.

Follow me on Twitter Reply With Quote
 
  #7 (permalink)
Thessaloniki, Greece
 
Experience: Beginner
Platform: QTS
Broker: IB
Trading: Equities, NQ
 
Posts: 165 since May 2012
Thanks: 104 given, 389 received

They put out a new update, it fixed the gateway issue.

Follow me on Twitter Reply With Quote
The following user says Thank You to imPairsonator for this post:
 
  #8 (permalink)
Site Administrator
Manta, Ecuador
 
Experience: Advanced
Platform: My own custom solution
Trading: Emini Futures
 
Big Mike's Avatar
 
Posts: 48,774 since Jun 2009
Thanks: 31,485 given, 94,155 received


imPairsonator View Post
They put out a new update, it fixed the gateway issue.

Confirmed, build 931.3 is working now.

Mike

We're here to help -- just ask

For the best trading education, watch our webinars
Searching for trading reviews? Review this list

Follow us on Twitter, YouTube, and Facebook

Support our community as an Elite Member:
https://futures.io/elite/
Follow me on Twitter Visit my Facebook Visit my futures io Trade Journal Reply With Quote



futures io Trading Community Platforms and Indicators > IB Gateway stuck on "Initializing environment"




Upcoming Webinars and Events
 

Free BloodHound Licenses to everyone!

June
 

Every journal equals ten meals for the hungry

June
     



Copyright © 2020 by futures io, s.a., Av Ricardo J. Alfaro, Century Tower, Panama, +507 833-9432, info@futures.io
All information is for educational use only and is not investment advice.
There is a substantial risk of loss in trading commodity futures, stocks, options and foreign exchange products. Past performance is not indicative of future results.
no new posts