help! - NT8 cannot establish proper connection - futures io
futures io futures trading



help! - NT8 cannot establish proper connection


Discussion in NinjaTrader

Updated by aronax
      Top Posters
    1. looks_one sam028 with 2 posts (5 thanks)
    2. looks_two DavidHP with 2 posts (4 thanks)
    3. looks_3 aronax with 2 posts (1 thanks)
    4. looks_4 xplorer with 1 posts (2 thanks)
      Best Posters
    1. looks_one sam028 with 2.5 thanks per post
    2. looks_two DavidHP with 2.0 thanks per post
    3. looks_3 xplorer with 2.0 thanks per post
    4. looks_4 aronax with 0.5 thanks per post
    1. trending_up 709 views
    2. thumb_up 12 thanks given
    3. group 3 followers
    1. forum 6 replies
    2. attach_file 2 attachments




Welcome to futures io: the largest futures trading community on the planet, with well over 100,000 members
  • Genuine reviews from real traders, not fake reviews from stealth vendors
  • Quality education from leading professional traders
  • We are a friendly, helpful, and positive community
  • We do not tolerate rude behavior, trolling, or vendors advertising in posts
  • We are here to help, just let us know what you need
You'll need to register in order to view the content of the threads and start contributing to our community.  It's free and simple.

-- Big Mike, Site Administrator

(If you already have an account, login at the top of the page)

 
Thread Tools Search this Thread
 

help! - NT8 cannot establish proper connection

  #1 (permalink)
Bruxelles + Belgium
 
 
Posts: 2 since Jul 2019
Thanks: 5 given, 1 received

help! - NT8 cannot establish proper connection

Greetings traders!

i am new to brussels and have recently installed ninjatrader8.
I have an internet connection from proximus and wanted to start trading trough oneup trader.
the problem i have is that when i try to connect i get an amber light instead of green and the data feed never comes through.

Tracing route to hds-us-nt-001.ninjatrader.com [208.48.16.146]
over a maximum of 30 hops:

2 141 ms 208 ms 198 ms 1.192-130-109.adsl-dyn.isp.belgacom.be [109.130.192.1]
3 8 ms 8 ms 8 ms ae-91-200.iarstr2.isp.belgacom.be [91.183.241.196]
4 9 ms 8 ms 8 ms ae-22-1000.ibrstr6.isp.belgacom.be [91.183.246.110]
5 9 ms 9 ms 8 ms 6-1-1.bear1.brussels1.level3.net [212.3.232.41]
6 * * * Request timed out.
7 102 ms 102 ms 102 ms cqg-inc.ear4.chicago2.level3.net [4.15.85.194]
8 102 ms 102 ms 102 ms 208.48.16.146

From what i understand the request times-out at a Level 3 server in Belgium, passes through but for some reason the data feed doesn't reach back the platform.

I have talked to OneUp Trader support and they validated the account as working ok. I then contacted NT support where they said that this should be resolved by the ISP provider and they as well validated the account on their side. After speaking with Proximus support line they said it is beyond their support level and that i should write on their support forum.... i did, but yeah, they couldn't help either.

Writing here in the hopes that someone might've experienced the same issue and would be able to help...

Thank you!
Chris

Reply With Quote
The following user says Thank You to aronax for this post:

Can you help answer these questions
from other members on futures io?
Convert NinjaTrader NT7 indicator to Tradestation EasyLanguage and RADARSCREEN
Platforms and Indicators
Issue meeting order entry conditions
Elite Automated NinjaTrader Trading
Last 5 minutes Label
ThinkOrSwim
Moving average with Lag reduction
NinjaTrader
Linux?
ThinkOrSwim
 
Best Threads (Most Thanked)
in the last 7 days on futures io
FIO Journal Challenge - June 2020 edition w/SharkIndicators
59 thanks
Spoo-nalysis ES e-mini futures S&P 500
56 thanks
June Charity Fundraiser - Feeding hungry families
51 thanks
Fixed vs trailing stops
28 thanks
AMP Futures / AMP Global Review
27 thanks
 
  #2 (permalink)
Super Moderator
London UK
 
Experience: Beginner
Platform: CQG
Broker: S5
Trading: Futures
 
xplorer's Avatar
 
Posts: 4,985 since Sep 2015
Thanks: 12,508 given, 11,196 received


aronax View Post
Greetings traders!

i am new to brussels and have recently installed ninjatrader8.
I have an internet connection from proximus and wanted to start trading trough oneup trader.
the problem i have is that when i try to connect i get an amber light instead of green and the data feed never comes through.

Tracing route to hds-us-nt-001.ninjatrader.com [208.48.16.146]
over a maximum of 30 hops:

2 141 ms 208 ms 198 ms 1.192-130-109.adsl-dyn.isp.belgacom.be [109.130.192.1]
3 8 ms 8 ms 8 ms ae-91-200.iarstr2.isp.belgacom.be [91.183.241.196]
4 9 ms 8 ms 8 ms ae-22-1000.ibrstr6.isp.belgacom.be [91.183.246.110]
5 9 ms 9 ms 8 ms 6-1-1.bear1.brussels1.level3.net [212.3.232.41]
6 * * * Request timed out.
7 102 ms 102 ms 102 ms cqg-inc.ear4.chicago2.level3.net [4.15.85.194]
8 102 ms 102 ms 102 ms 208.48.16.146

From what i understand the request times-out at a Level 3 server in Belgium, passes through but for some reason the data feed doesn't reach back the platform.

I have talked to OneUp Trader support and they validated the account as working ok. I then contacted NT support where they said that this should be resolved by the ISP provider and they as well validated the account on their side. After speaking with Proximus support line they said it is beyond their support level and that i should write on their support forum.... i did, but yeah, they couldn't help either.

Writing here in the hopes that someone might've experienced the same issue and would be able to help...

Thank you!
Chris

Could your firewall configuration or antivirus be blocking the connection?

Reply With Quote
The following 2 users say Thank You to xplorer for this post:
 
  #3 (permalink)
Market Wizard
New Orleans, La (Mardi Gras City)
 
Experience: Advanced
Platform: NinjaTrader
Broker: Ninjatrader / Optimus Futures / AmpFutures
Trading: ES / 6E / 6B / CL
 
DavidHP's Avatar
 
Posts: 1,339 since Aug 2009
Thanks: 9,303 given, 2,323 received



aronax View Post

Writing here in the hopes that someone might've experienced the same issue and would be able to help...

Thank you!
Chris

It is probably a port block from your ISP.
You can contact NT to ask which ports they use for NT8 and then check to see if they are open through your provider.

I had that issue at work years ago and it was one of the ports being blocked.
Once it was open, it worked well.

FWIW

Rejoice in the Thunderstorms of Life . . .
Knowing it's not about Clouds or Wind. . .
But Learning to Dance in the Rain ! ! !
Follow me on Twitter Reply With Quote
The following 3 users say Thank You to DavidHP for this post:
 
  #4 (permalink)
Administrator: Retired Backtester
Rennes France
 
Experience: Advanced
Platform: NinjaTrader
Broker: IB/Kinetick
Trading: Futures
 
sam028's Avatar
 
Posts: 3,617 since Jun 2009
Thanks: 3,755 given, 4,420 received


aronax View Post
Greetings traders!

i am new to brussels and have recently installed ninjatrader8.
I have an internet connection from proximus and wanted to start trading trough oneup trader.
the problem i have is that when i try to connect i get an amber light instead of green and the data feed never comes through.

Tracing route to hds-us-nt-001.ninjatrader.com [208.48.16.146]
over a maximum of 30 hops:

2 141 ms 208 ms 198 ms 1.192-130-109.adsl-dyn.isp.belgacom.be [109.130.192.1]
3 8 ms 8 ms 8 ms ae-91-200.iarstr2.isp.belgacom.be [91.183.241.196]
4 9 ms 8 ms 8 ms ae-22-1000.ibrstr6.isp.belgacom.be [91.183.246.110]
5 9 ms 9 ms 8 ms 6-1-1.bear1.brussels1.level3.net [212.3.232.41]
6 * * * Request timed out.
7 102 ms 102 ms 102 ms cqg-inc.ear4.chicago2.level3.net [4.15.85.194]
8 102 ms 102 ms 102 ms 208.48.16.146

From what i understand the request times-out at a Level 3 server in Belgium, passes through but for some reason the data feed doesn't reach back the platform.

I have talked to OneUp Trader support and they validated the account as working ok. I then contacted NT support where they said that this should be resolved by the ISP provider and they as well validated the account on their side. After speaking with Proximus support line they said it is beyond their support level and that i should write on their support forum.... i did, but yeah, they couldn't help either.

Writing here in the hopes that someone might've experienced the same issue and would be able to help...

Thank you!
Chris

No no, sorry for my dear @xplorer and @DavidHP , but there is no problem at all with your tracert and your network is fine.
A request time out on router 6 is not a problem: this router do not reply to ICMP packets but do its job. If there were a problem here you won't see router 7 and the final destination.

See what I see on one of my machines: router 2 is showing this timed out but the communication can be established:
PS C:\Users\Administrator> tracert -d 208.48.16.146

Tracing route to 208.48.16.146 over a maximum of 30 hops

1 <1 ms <1 ms <1 ms 10.0.86.1
2 * * * Request timed out.
3 1 ms <1 ms <1 ms 216.86.150.174
...
7 2 ms 1 ms 1 ms 4.15.85.194
8 1 ms 1 ms 1 ms 208.48.16.146

Trace complete.
PS C:\Users\Administrator> ping 208.48.16.146

Pinging 208.48.16.146 with 32 bytes of data:
Reply from 208.48.16.146: bytes=32 time=1ms TTL=122
Reply from 208.48.16.146: bytes=32 time=1ms TTL=122
Reply from 208.48.16.146: bytes=32 time=1ms TTL=122
Reply from 208.48.16.146: bytes=32 time=1ms TTL=122

Ping statistics for 208.48.16.146:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 1ms, Average = 1ms
PS C:\Users\Administrator>


The problem is somewhere else, try use a VPN or a 4G network as a proxy to confirm (but I'm 100% it's not a network/routing problem).

Success requires no deodorant! (Sun Tzu)
Follow me on Twitter Reply With Quote
The following 4 users say Thank You to sam028 for this post:
 
  #5 (permalink)
Market Wizard
New Orleans, La (Mardi Gras City)
 
Experience: Advanced
Platform: NinjaTrader
Broker: Ninjatrader / Optimus Futures / AmpFutures
Trading: ES / 6E / 6B / CL
 
DavidHP's Avatar
 
Posts: 1,339 since Aug 2009
Thanks: 9,303 given, 2,323 received


sam028 View Post
The problem is somewhere else, try use a VPN or a 4G network as a proxy to confirm (but I'm 100% it's not a network/routing problem).

@sam028 has a great suggestion, try a VPN to confirm.

If a port is blocked by a local or ISP router you can still get ping/tracert.

When my office network blocked the ports NT used, I had no issues with ping or tracert to the server but I could not connect to the trade or data server.

Unfortunately, I can't access the emails between the office IT dept and myself to reveal which ports were blocked.
If I remember correctly the port in question was 36973 for NT7.

NT 8 Probably has a different port assignment.

Also, there is a licensing port used by NT as well as a data provider port. If you can find the ports needed you can use this command in a Windows Powershell to test the port being open or closed.
 
Code
Test-NetConnection -ComputerName localhost -Port <PUT NUMBER HERE>
(Using Wireshark is one method to find ports used)

If I am incorrect, sorry for the interruption.

Rejoice in the Thunderstorms of Life . . .
Knowing it's not about Clouds or Wind. . .
But Learning to Dance in the Rain ! ! !
Follow me on Twitter Reply With Quote
The following user says Thank You to DavidHP for this post:
 
  #6 (permalink)
Administrator: Retired Backtester
Rennes France
 
Experience: Advanced
Platform: NinjaTrader
Broker: IB/Kinetick
Trading: Futures
 
sam028's Avatar
 
Posts: 3,617 since Jun 2009
Thanks: 3,755 given, 4,420 received

Easier and without installing anything you can see which process is connected to what using the Windows Resource Monitor:
One other test would be to disable the local firewall, but it should not be the problem.
I don't think the ISP is blocking some ports, this would be extremely unusual.

Success requires no deodorant! (Sun Tzu)
Follow me on Twitter Reply With Quote
The following user says Thank You to sam028 for this post:
 
  #7 (permalink)
Bruxelles + Belgium
 
 
Posts: 2 since Jul 2019
Thanks: 5 given, 1 received

First of all, thank you all for your replies.

I have disabled both firewall and antivirus and the issue remains.
I believe you are right @sam028 as this might not be a connection issue (though i am not an expert).

as you can see the ports used are not blocked:



i will look into a VPN and see if this solves the problem.

Cheers!
Chris

Reply With Quote



futures io Trading Community Platforms and Indicators NinjaTrader > help! - NT8 cannot establish proper connection




Upcoming Webinars and Events
 

Free BloodHound Licenses for everyone!

June
 

Every journal equals ten meals for the hungry

June
     



Copyright © 2020 by futures io, s.a., Av Ricardo J. Alfaro, Century Tower, Panama, +507 833-9432, info@futures.io
All information is for educational use only and is not investment advice.
There is a substantial risk of loss in trading commodity futures, stocks, options and foreign exchange products. Past performance is not indicative of future results.
no new posts