Renko bars not working in NT7 - futures io
futures io



Renko bars not working in NT7


Discussion in NinjaTrader

Updated
      Top Posters
    1. looks_one aslan with 16 posts (40 thanks)
    2. looks_two zikonc with 14 posts (1 thanks)
    3. looks_3 RJay with 11 posts (7 thanks)
    4. looks_4 Todd with 8 posts (0 thanks)
      Best Posters
    1. looks_one roonius with 3.3 thanks per post
    2. looks_two gregid with 3.1 thanks per post
    3. looks_3 aslan with 2.5 thanks per post
    4. looks_4 RJay with 0.6 thanks per post
    1. trending_up 34,003 views
    2. thumb_up 89 thanks given
    3. group 21 followers
    1. forum 109 posts
    2. attach_file 24 attachments




Welcome to futures io: the largest futures trading community on the planet, with well over 125,000 members
  • Genuine reviews from real traders, not fake reviews from stealth vendors
  • Quality education from leading professional traders
  • We are a friendly, helpful, and positive community
  • We do not tolerate rude behavior, trolling, or vendors advertising in posts
  • We are here to help, just let us know what you need
You'll need to register in order to view the content of the threads and start contributing to our community.  It's free and simple.

-- Big Mike, Site Administrator

(If you already have an account, login at the top of the page)

 
Search this Thread
 

Renko bars not working in NT7

(login for full post details)
  #101 (permalink)
 TheWizard 
Houston, TX
 
Experience: Intermediate
Platform: NinjaTrader
Broker: Optimus Futures, AMP, CQG
Trading: 6E
 
TheWizard's Avatar
 
Posts: 1,736 since Jun 2009
Thanks: 517 given, 4,215 received


Hapster View Post
Thanks, but did that. Still no listing of anything other than minute bars....

H

Post a screenshot of your TYPE folder
(Documents>Bin>Custom>Type).

My guess would be that you have a conflicting bar type that is overriding the one you want to see (Case Bars, SBSRenko, BetterRenko, MedianRenko, etc).

Here's a sample of my TYPE folder. See what non "@" type bar types you have in your folder. One of them is most likely the culprit.

Another test: Move all non "@" bar types OUT of your TYPE folder and into a folder on your desktop (call it anything you like). Make sure they are gone from your TYPE folder. Re-import WickedRenko. Shutdown Ninja. Restart Ninja & then Wicked Renko should appear in your Data Series window along with minute, range, volume, etc..

Just a guess, but it might help resolve the problem.

NOTE: WickedRenko, MedianRenko, etc are NOT going to show up in the INTERVAL pull-down menu. They will show up in the DATA SERIES pull-down menu.

After all, it's what you learn AFTER you know it all, that counts!
Attached Thumbnails
Click image for larger version

Name:	TYPE folder.jpg
Views:	162
Size:	115.1 KB
ID:	31974   Click image for larger version

Name:	Data Series.jpg
Views:	174
Size:	70.6 KB
ID:	31979  
Reply With Quote
The following user says Thank You to TheWizard for this post:
 
(login for full post details)
  #102 (permalink)
 gregid 
Wrocław, Poland
 
Experience: Intermediate
Platform: NinjaTrader, Racket
Trading: Ockham's razor
 
gregid's Avatar
 
Posts: 651 since Aug 2009
Thanks: 320 given, 620 received

if you are talking about changing it from the chart that is already open -> press the red/green button next to the button that starts chart trader - they actually look quite similar!

That's where you change the data series...

Reply With Quote
The following user says Thank You to gregid for this post:
 
(login for full post details)
  #103 (permalink)
 Hapster 
San Diego, California
 
Experience: Intermediate
Platform: NinjaTrader, Felton
Trading: CL, GC
 
Hapster's Avatar
 
Posts: 141 since Aug 2009
Thanks: 40 given, 81 received

Ah... thanks, guys..... well, I'm ALMOST there.... I see now in the Data Series window how I need to change the interval to something other than minutes. However, now when I choose a Renko bar and the tick size and then hit "Apply" the window closes and the chart comes up with the Renko bar setting up in the upper left of the chart next to the instrument, but it's all grey and doesn't populate with bars and just sits there.

Also, I can't find a Type folder below the BIN/CUSTOM folder. The only folder in the CUSTOM folder is BACKUP.

Thanks, guys... I really appreciate you dealing with my thickness on this!!!

H

Follow me on Twitter Visit my futures io Trade Journal Reply With Quote
 
(login for full post details)
  #104 (permalink)
 TheWizard 
Houston, TX
 
Experience: Intermediate
Platform: NinjaTrader
Broker: Optimus Futures, AMP, CQG
Trading: 6E
 
TheWizard's Avatar
 
Posts: 1,736 since Jun 2009
Thanks: 517 given, 4,215 received


Hapster View Post
Ah... thanks, guys..... well, I'm ALMOST there.... I see now in the Data Series window how I need to change the interval to something other than minutes. However, now when I choose a Renko bar and the tick size and then hit "Apply" the window closes and the chart comes up with the Renko bar setting up in the upper left of the chart next to the instrument, but it's all grey and doesn't populate with bars and just sits there.

Also, I can't find a Type folder below the BIN/CUSTOM folder. The only folder in the CUSTOM folder is BACKUP.

Thanks, guys... I really appreciate you dealing with my thickness on this!!!

H

You need to do one of two things. Disconnect - reconnect to data feed, or Reload All Historical Data (CRTL+SHIFT+R, by right-clicking on your chart).

If Reload All Historical Data is 'grayed out', you'll need to go under:
Control Center>Tools>Options then select the DATA tab & click the REPAIR DB button. This will repair the data base.
Then try to connect to your data feed or Right-Click on your chart & Reload All Historical Data.

That should cause the chart to repopulate with data bars. Make sure you've set it to load a few days worth of data (2, 3, 4 days back, etc) in the Data Series window. I think it defaults to '1' day. You may want more days' data on the chart than that.

After all, it's what you learn AFTER you know it all, that counts!
Reply With Quote
The following user says Thank You to TheWizard for this post:
 
(login for full post details)
  #105 (permalink)
 Hapster 
San Diego, California
 
Experience: Intermediate
Platform: NinjaTrader, Felton
Trading: CL, GC
 
Hapster's Avatar
 
Posts: 141 since Aug 2009
Thanks: 40 given, 81 received

Hi, Wizard...

Nope... followed all your instructions and still grey only with Renko bars....

Thanks, anyhow...

I'm testing this out with a separate laptop due to the message I got regarding the Windows 7 Service Pack 1 issue. I think I'll just NOT load SP1 and keep running 6.5 on my main computer. It's working, and there are a few indicators I need that I have that WORK in 6.5.

Whatever.... thanks again for your help, though. Much appreciated.

H

Follow me on Twitter Visit my futures io Trade Journal Reply With Quote
 
(login for full post details)
  #106 (permalink)
 Eubie 
Prague, Czech republic
 
Experience: Beginner
Platform: NinjaTrader/ZF
Trading: ES, TF
 
Posts: 87 since Jul 2010
Thanks: 128 given, 47 received

Hello everybody,

Im having difficulty using WickedRenko. I tried using BetterRenko/BetterBrick, but WickedRenko is just the best to me. it's much cleaner. From time to time, when I start market replay, nothing appears and Ninja just grows in memory while producing no output and nothing helps. It usually lasts for a couple of days till this behavior goes away. I tried other Renkos and neither produces this behavior. I have the latest WickedRenko version (V2). Is there any hint related to how to remove this bug? I have only one chart open in the workspace, so I guess it can't be the template stuff, which is anyway corrected in V2, if I'm correct.

Included is a screenshot that demonstrates it, trying to open a WickedRenko4 chart on replay.

Any suggestion si highly appreciated.
Daniel

Reply With Quote
 
(login for full post details)
  #107 (permalink)
 RJay 
Hartford, CT. USA
 
Experience: Intermediate
Platform: NinjaTrader
Broker: AMP/CQG, Kinetick
Trading: RTY
 
RJay's Avatar
 
Posts: 688 since Jun 2009
Thanks: 748 given, 781 received

Hi Eubie,

Are you using chart templates on your charts. Some Renko style chart templates are not interchangeable with other Renko charts..

load your charts clean first to load historic data. Then add indicators.

RJay



Eubie View Post
Hello everybody,

Im having difficulty using WickedRenko. I tried using BetterRenko/BetterBrick, but WickedRenko is just the best to me. it's much cleaner. From time to time, when I start market replay, nothing appears and Ninja just grows in memory while producing no output and nothing helps. It usually lasts for a couple of days till this behavior goes away. I tried other Renkos and neither produces this behavior. I have the latest WickedRenko version (V2). Is there any hint related to how to remove this bug? I have only one chart open in the workspace, so I guess it can't be the template stuff, which is anyway corrected in V2, if I'm correct.

Included is a screenshot that demonstrates it, trying to open a WickedRenko4 chart on replay.

Any suggestion si highly appreciated.
Daniel


Reply With Quote
 
(login for full post details)
  #108 (permalink)
 Eubie 
Prague, Czech republic
 
Experience: Beginner
Platform: NinjaTrader/ZF
Trading: ES, TF
 
Posts: 87 since Jul 2010
Thanks: 128 given, 47 received


RJay View Post
Hi Eubie,

Are you using chart templates on your charts. Some Renko style chart templates are not interchangeable with other Renko charts..

load your charts clean first to load historic data. Then add indicators.

RJay


Hello RJay!

Well, I have a feeling that it will have sth to do with session start. An example.. if the replay starts with Jan 9th, 2012 everything is fine. When I delete this replay file and my "replay database" starts on Jan 10th, 2012 the problem appears. When I have both 9th and 10th in the dbase, I connect to replay and everything goes fine. Once I type in "1/10/2012" into "From" i have a problem again. However, if I speed up the process 500x and actually "roll over" 9th of January into Jan 10th, I get no problems. So I think it will not be connected to templates. Sometimes I wish ninja ws surprise-free

Reply With Quote
 
(login for full post details)
  #109 (permalink)
 maxima 
London
 
Experience: Intermediate
Platform: XT
 
Posts: 49 since Jan 2010

I was trying to find wicked and sbs in the elite download area but couldnt find them. am i missing something or they are not there?

i found some zips in the old threads but not sure if they are the latests... please advice

Reply With Quote
 
(login for full post details)
  #110 (permalink)
 trendisyourfriend 
Legendary Market Wizard
Quebec
 
Experience: Intermediate
Platform: NinjaTrader wt Rancho Dinero's profiling tools
Broker: AMP/CQG
Trading: ES, NQ, YM
 
trendisyourfriend's Avatar
 
Posts: 4,051 since Oct 2009
Thanks: 3,702 given, 5,242 received


maxima View Post
I was trying to find wicked and sbs in the elite download area but couldnt find them. am i missing something or they are not there?

i found some zips in the old threads but not sure if they are the latests... please advice

WickedRenko v1

SbS Renko

Reply With Quote
The following user says Thank You to trendisyourfriend for this post:


futures io Trading Community Platforms and Indicators NinjaTrader > Renko bars not working in NT7


Last Updated on January 23, 2012


Upcoming Webinars and Events
 

NinjaTrader Indicator Challenge!

Ongoing
 

Our 12-year anniversary w/ $$,$$$ prizes (check soon)

June
     



Copyright © 2021 by futures io, s.a., Av Ricardo J. Alfaro, Century Tower, Panama, Ph: +507 833-9432 (Panama and Intl), +1 888-312-3001 (USA and Canada), info@futures.io
All information is for educational use only and is not investment advice.
There is a substantial risk of loss in trading commodity futures, stocks, options and foreign exchange products. Past performance is not indicative of future results.
no new posts