NT7 compatibility - futures io
futures io futures trading



NT7 compatibility


Discussion in NinjaTrader

Updated February 21st 2020 by loantelligence
      Top Posters
    1. looks_one ZTR with 17 posts (13 thanks)
    2. looks_two Big Mike with 14 posts (5 thanks)
    3. looks_3 Fat Tails with 13 posts (21 thanks)
    4. looks_4 ivanjocic with 9 posts (9 thanks)
      Best Posters
    1. looks_one Mindset with 2.5 thanks per post
    2. looks_two Fat Tails with 1.6 thanks per post
    3. looks_3 ivanjocic with 1.0 thanks per post
    4. looks_4 ZTR with 0.8 thanks per post
    1. trending_up 41,101 views
    2. thumb_up 96 thanks given
    3. group 35 followers
    1. forum 135 replies
    2. attach_file 49 attachments




Welcome to futures io: the largest futures trading community on the planet, with well over 100,000 members
  • Genuine reviews from real traders, not fake reviews from stealth vendors
  • Quality education from leading professional traders
  • We are a friendly, helpful, and positive community
  • We do not tolerate rude behavior, trolling, or vendors advertising in posts
  • We are here to help, just let us know what you need
You'll need to register in order to view the content of the threads and start contributing to our community.  It's free and simple.

-- Big Mike, Site Administrator

(If you already have an account, login at the top of the page)

 
Search this Thread
 

NT7 compatibility

(login for full post details)
  #1 (permalink)
Administrator: Retired Backtester
Rennes France
 
Experience: Advanced
Platform: NinjaTrader
Broker: IB/Kinetick
Trading: Futures
 
sam028's Avatar
 
Posts: 3,617 since Jun 2009
Thanks: 3,755 given, 4,420 received

NT7 compatibility

Dear genius coders, we are trying to see which futures.io (formerly BMT) hosted indicators (here) are NT7 compatible, and which are not.
If some of you are able to test some of them, and then give us your feedback on it, it will benefit to everybody .

Then we could modified the indicator's description, with this useful information.

Thanks !!!

Success requires no deodorant! (Sun Tzu)
Follow me on Twitter Reply With Quote
The following 3 users say Thank You to sam028 for this post:

Can you help answer these questions
from other members on futures io?
Convert NinjaTrader NT7 indicator to Tradestation EasyLanguage and RADARSCREEN
Platforms and Indicators
Issue meeting order entry conditions
Elite Automated NinjaTrader Trading
Last 5 minutes Label
ThinkOrSwim
Moving average with Lag reduction
NinjaTrader
Linux?
ThinkOrSwim
 
 
(login for full post details)
  #2 (permalink)
Site Administrator
Manta, Ecuador
 
Experience: Advanced
Platform: My own custom solution
Trading: Emini Futures
 
Big Mike's Avatar
 
Posts: 48,786 since Jun 2009
Thanks: 31,500 given, 94,188 received

For starters, I know the CMI v7.5 does not work in NT 7. I have not had time to see if the author has a newer version. I've marked it as not-compatible in download section.



Mike

We're here to help -- just ask

For the best trading education, watch our webinars
Searching for trading reviews? Review this list

Follow us on Twitter, YouTube, and Facebook

Support our community as an Elite Member:
https://futures.io/elite/
Follow me on Twitter Visit my Facebook Visit my futures io Trade Journal Reply With Quote
 
(login for full post details)
  #3 (permalink)
Site Administrator
Manta, Ecuador
 
Experience: Advanced
Platform: My own custom solution
Trading: Emini Futures
 
Big Mike's Avatar
 
Posts: 48,786 since Jun 2009
Thanks: 31,500 given, 94,188 received


Let me also report the futures.io (formerly BMT) Envelope Fib Bands won't import as-is, it is a conflict in VWAP. I will fix it in next version.



I marked them as "no".

Mike

We're here to help -- just ask

For the best trading education, watch our webinars
Searching for trading reviews? Review this list

Follow us on Twitter, YouTube, and Facebook

Support our community as an Elite Member:
https://futures.io/elite/
Follow me on Twitter Visit my Facebook Visit my futures io Trade Journal Reply With Quote
 
(login for full post details)
  #4 (permalink)
Site Administrator
Manta, Ecuador
 
Experience: Advanced
Platform: My own custom solution
Trading: Emini Futures
 
Big Mike's Avatar
 
Posts: 48,786 since Jun 2009
Thanks: 31,500 given, 94,188 received

Last, let me say that futures.io (formerly BMT) PaintBar Close imports fine, but I listed it as 'not tested' at the moment because NT7 beta 5 has a bug regarding CandleStickBorder colors, which this indicator uses.

I will have to wait until beta 6, or later, when they fix the bug, to make sure no code changes are needed for NT7 use.



Mike

We're here to help -- just ask

For the best trading education, watch our webinars
Searching for trading reviews? Review this list

Follow us on Twitter, YouTube, and Facebook

Support our community as an Elite Member:
https://futures.io/elite/
Follow me on Twitter Visit my Facebook Visit my futures io Trade Journal Reply With Quote
 
(login for full post details)
  #5 (permalink)
Administrator: Retired Backtester
Rennes France
 
Experience: Advanced
Platform: NinjaTrader
Broker: IB/Kinetick
Trading: Futures
 
sam028's Avatar
 
Posts: 3,617 since Jun 2009
Thanks: 3,755 given, 4,420 received

I'm checking some indicators compatibility, but not very deeply:
- import/compilation OK
- plot what it's supposed to be plotted
And that's it, no backtests with strategies using these indicators, for example, so, be careful .

Success requires no deodorant! (Sun Tzu)
Follow me on Twitter Reply With Quote
 
(login for full post details)
  #6 (permalink)
Wrocław, Poland
 
Experience: Intermediate
Platform: NinjaTrader, Racket
Trading: Ockham's razor
 
gregid's Avatar
 
Posts: 651 since Aug 2009
Thanks: 320 given, 617 received

I've noticed that SBSRanko by roonius is not NT7 compatible - although it is a chart type not an indicator (and it is in Misc section) I believe it should have compatibility indication:


Reply With Quote
The following user says Thank You to gregid for this post:
 
(login for full post details)
  #7 (permalink)
Administrator: Retired Backtester
Rennes France
 
Experience: Advanced
Platform: NinjaTrader
Broker: IB/Kinetick
Trading: Futures
 
sam028's Avatar
 
Posts: 3,617 since Jun 2009
Thanks: 3,755 given, 4,420 received


gregid View Post
I've noticed that SBSRanko by roonius is not NT7 compatible - although it is a chart type not an indicator (and it is in Misc section) I believe it should have compatibility indication:


From the author, Roonius, here: "NT 7 has their own Renko, so I feel it's NT duties to deal with it now."

Success requires no deodorant! (Sun Tzu)
Follow me on Twitter Reply With Quote
 
(login for full post details)
  #8 (permalink)
Site Administrator
Manta, Ecuador
 
Experience: Advanced
Platform: My own custom solution
Trading: Emini Futures
 
Big Mike's Avatar
 
Posts: 48,786 since Jun 2009
Thanks: 31,500 given, 94,188 received


gregid View Post
I've noticed that SBSRanko by roonius is not NT7 compatible - although it is a chart type not an indicator (and it is in Misc section) I believe it should have compatibility indication:


Thx greg, I updated the description.

Mike

We're here to help -- just ask

For the best trading education, watch our webinars
Searching for trading reviews? Review this list

Follow us on Twitter, YouTube, and Facebook

Support our community as an Elite Member:
https://futures.io/elite/
Follow me on Twitter Visit my Facebook Visit my futures io Trade Journal Reply With Quote
 
(login for full post details)
  #9 (permalink)
POrtugal
 
 
Posts: 54 since Nov 2009

NT6-NT7 indicator

hello,

Can some one fix the error of the pivot indicator that is atteched?
I get an error in line 321 when inporting in NT7.

thanks

Attached Files
Register to download File Type: cs CMIPivotsDailyV6.cs (52.6 KB, 13 views)
Reply With Quote
 
(login for full post details)
  #10 (permalink)
POrtugal
 
 
Posts: 54 since Nov 2009


Other indicatores with errors when importing in NT7:

Realstats_sharkypkg
Priceline_indicator_v2
rangealtbarstype
NoGapRangeBars

Moderator Notice
Moderator Notice


Attached Files
Register to download File Type: cs RealStats_SharkyPkg.cs (33.3 KB, 37 views)
Register to download File Type: cs PriceLine_Indicator_V_2.cs (9.1 KB, 36 views)
Register to download File Type: zip RangeAltBarsType.zip (1.5 KB, 45 views)
Reply With Quote


futures io Trading Community Platforms and Indicators NinjaTrader > NT7 compatibility


February 21, 2020


Upcoming Webinars and Events
 

Free BloodHound Licenses for everyone!

June
 

Every journal equals ten meals for the hungry

June
     



Copyright © 2020 by futures io, s.a., Av Ricardo J. Alfaro, Century Tower, Panama, +507 833-9432, info@futures.io
All information is for educational use only and is not investment advice.
There is a substantial risk of loss in trading commodity futures, stocks, options and foreign exchange products. Past performance is not indicative of future results.
no new posts