NT7 compatibility - NinjaTrader Programming | futures io social day trading
futures io futures trading


NT7 compatibility
Updated: Views / Replies:34,393 / 134
Created: by sam028 Attachments:47

Welcome to futures io.

(If you already have an account, login at the top of the page)

futures io is the largest futures trading community on the planet, with over 90,000 members. At futures io, our goal has always been and always will be to create a friendly, positive, forward-thinking community where members can openly share and discuss everything the world of trading has to offer. The community is one of the friendliest you will find on any subject, with members going out of their way to help others. Some of the primary differences between futures io and other trading sites revolve around the standards of our community. Those standards include a code of conduct for our members, as well as extremely high standards that govern which partners we do business with, and which products or services we recommend to our members.

At futures io, our focus is on quality education. No hype, gimmicks, or secret sauce. The truth is: trading is hard. To succeed, you need to surround yourself with the right support system, educational content, and trading mentors Ė all of which you can find on futures io, utilizing our social trading environment.

With futures io, you can find honest trading reviews on brokers, trading rooms, indicator packages, trading strategies, and much more. Our trading review process is highly moderated to ensure that only genuine users are allowed, so you donít need to worry about fake reviews.

We are fundamentally different than most other trading sites:
  • We are here to help. Just let us know what you need.
  • We work extremely hard to keep things positive in our community.
  • We do not tolerate rude behavior, trolling, or vendors advertising in posts.
  • We firmly believe in and encourage sharing. The holy grail is within you, we can help you find it.
  • We expect our members to participate and become a part of the community. Help yourself by helping others.

You'll need to register in order to view the content of the threads and start contributing to our community.  It's free and simple.

-- Big Mike, Site Administrator

Reply
 47  
 
Thread Tools Search this Thread
 

NT7 compatibility

  #21 (permalink)
Elite Member
Madison, WI
 
Futures Experience: Advanced
Platform: Sierra Charts, ALT
Favorite Futures: ES
 
aslan's Avatar
 
Posts: 614 since Jan 2010
Thanks: 342 given, 1,077 received


jsengxx View Post
Tanks....

Do you have a solution for the rangealtbarstype??

Look at this NT thread for a NT 7 version of RangeAltBars:

Pleading for RangeAlt bars - NinjaTrader Support Forum

Reply With Quote
The following user says Thank You to aslan for this post:
 
  #22 (permalink)
Elite Member
london uk
 
Futures Experience: Beginner
Platform: NinjaTrader
Broker/Data: Zen-Fire
Favorite Futures: Stocks
 
tellytub's Avatar
 
Posts: 409 since Jun 2009
Thanks: 333 given, 118 received

This also does not work in N7

Attached Files
Register to download File Type: cs MedianRenko.cs (5.1 KB, 6 views)
Reply With Quote
The following user says Thank You to tellytub for this post:
 
  #23 (permalink)
Elite Member
london uk
 
Futures Experience: Beginner
Platform: NinjaTrader
Broker/Data: Zen-Fire
Favorite Futures: Stocks
 
tellytub's Avatar
 
Posts: 409 since Jun 2009
Thanks: 333 given, 118 received


RSqueeze works on N7

Reply With Quote
The following user says Thank You to tellytub for this post:
 
  #24 (permalink)
 R.I.P. 1960-2010 
 
Futures Experience: Advanced
Platform: NinjaTrader7
Broker/Data: Mirus RCG/Zen-Fire
Favorite Futures: CL & 6e, looking at ES, ZB and AU again.
 
ZTR's Avatar
 
Posts: 2,099 since Nov 2009
Thanks: 1,104 given, 1,390 received

Murrey Math for NT7

I got NT Support to help me and I have posted it to the downloads section.

Attached Thumbnails
NT7 compatibility-es-03-10-1-min-2_4_2010_mm_nt7.jpg  
Reply With Quote
The following 2 users say Thank You to ZTR for this post:
 
  #25 (permalink)
 R.I.P. 1960-2010 
 
Futures Experience: Advanced
Platform: NinjaTrader7
Broker/Data: Mirus RCG/Zen-Fire
Favorite Futures: CL & 6e, looking at ES, ZB and AU again.
 
ZTR's Avatar
 
Posts: 2,099 since Nov 2009
Thanks: 1,104 given, 1,390 received

Procedure to upgrade to new version of NT

I have learned the hard way. NT 7, like a lot of Windows apps, requires a clean install.

I recommend:
  • Run a Backup (Files>Utilities>Backup - although it does not always help, can cause problems later)
  • Save the backup
  • Uninstall all previous NT versions including 6.5 if it is on the same computer (Revo is good at cleaning up stray files from .exe's)
  • Remove all folders used by NT 7 & 6.5
  • Clean the disk using the Windows Utility to remove unwanted files
  • Defragment the Hard Drive - Defraggler is free and way faster than the Windows version
  • Run CHKDSK - to make sure the hard drive is in good shape - can take a long, long time & is not necessary every time.
  • Download NT 7 (& 6.5 if you want to run both on the same system) and install
  • Run Restore (Files>Utilities>Restore) -It worked for 7b12.

Back your files up anytime you make an important change. I use a Network Drive to back up my computers.


Yes, it is time consuming, but It is worth all the effort.


Last edited by ZTR; March 26th, 2010 at 03:26 PM. Reason: II used this for 7b12 and want to update using the rebuild feature
Reply With Quote
The following 5 users say Thank You to ZTR for this post:
 
  #26 (permalink)
Elite Member
london uk
 
Futures Experience: Beginner
Platform: NinjaTrader
Broker/Data: Zen-Fire
Favorite Futures: Stocks
 
tellytub's Avatar
 
Posts: 409 since Jun 2009
Thanks: 333 given, 118 received

VolumeStopV3Bnew, does not work on N7

Reply With Quote
The following user says Thank You to tellytub for this post:
 
  #27 (permalink)
 R.I.P. 1960-2010 
 
Futures Experience: Advanced
Platform: NinjaTrader7
Broker/Data: Mirus RCG/Zen-Fire
Favorite Futures: CL & 6e, looking at ES, ZB and AU again.
 
ZTR's Avatar
 
Posts: 2,099 since Nov 2009
Thanks: 1,104 given, 1,390 received

Please Share NT7 Incompatible programs with me

Striving to get as much stuff working on Ninja Trader 7 as possiblle will give this forum's members more impact on what Ninja Trader Produces as the offical release of NT 7.01

Currently, collecting a list of Indicators that are incompatable when moved from 6.5 top 7. Some of it code break stuff and easy. If I see enough of them I'll develop a feel for the easy vs. hard fixes.

Really important suff like the 1000 time down-loaded Murray Math I took to NT support and had a fix in minutes. For other, like adapting Big Mike's futures.io (formerly BMT)EnvelopExpander to 7, I asked one of the really good coders on the Forum and he gave me an answer that allow me to have a compiled version in less than a minute.

I will do my best. Proirities are Highest # of downloads, what the other Modererators feel is important and what ever Big Mike wants done. Not necessarly in that order.

If we keep the majority of Beta stuff in this thread & other development threads and working suff in the download section (please put all indicators, workspaces, etc. in the download section, and remember your key words, please) and just link it to the thread it will be easier for everyone to find stuff.

Thanks,
Andy


Last edited by ZTR; February 5th, 2010 at 12:34 PM. Reason: I'm a bad typist
Reply With Quote
The following 2 users say Thank You to ZTR for this post:
 
  #28 (permalink)
 R.I.P. 1960-2010 
 
Futures Experience: Advanced
Platform: NinjaTrader7
Broker/Data: Mirus RCG/Zen-Fire
Favorite Futures: CL & 6e, looking at ES, ZB and AU again.
 
ZTR's Avatar
 
Posts: 2,099 since Nov 2009
Thanks: 1,104 given, 1,390 received

How to convert an NT 6.5 Indicator to NT 7

The point of this post is to show that even I can do this. So you can to.

The biggest changes between NT 6.5 & 7 is that the drawing elements and arrray are different. I'll leave the array stuff to real coders like Gomi, Zondor, RJay, Mike, Sharky, and the rest of you who are code artists.

But minor Code Breaks are easy to fix.

Take VolumeStopRefreshv4 that I changed to work with NT7

First import the indicator, then try to compile. You will get lots of error mostly to do with Draw statements.

One you get the error screen like shown below. Hit F1, then go to the search tab in the and type in the name of the element that has changed. In this case DrawText.

look at the new requirements:

DrawText(CurrentBar.ToString()+"l2" , true, "l", 0 , savePos2, 1, colorUD, textFont1, StringAlignment.Center, Color.Empty, Color.Empty, 1);

//DrawText(string tag, . . . . . . bool autoScale, string text, int barsAgo, double y, int yPixelOffset, Color textColor, Font font, StringAlignment alignment, Color outlineColor, Color areaColor, int areaOpacity)

I paste what I find below the line, comment it out and match up each field until I have spotted the problem. In this case true needs to be added, because there is now a auto scale field that is a bool type.

Do this for all the errors like DrawRay, DrawTriangle, etc. and eventually the code will compile.

Attached Thumbnails
NT7 compatibility-fixcomplieerror.jpg   NT7 compatibility-fixcomplieerror_help.jpg  
Reply With Quote
The following user says Thank You to ZTR for this post:
 
  #29 (permalink)
Trading for Fun
New York, NY
 
Futures Experience: Advanced
Platform: NinjaTrader
Broker/Data: Amp Futures/Zen-Fire
Favorite Futures: ES
 
Posts: 142 since Dec 2009
Thanks: 41 given, 83 received

Big Mike's DoubleMA. Was told by a friend that it doesn't work on 7.

Good luck!

Attached Files
Register to download File Type: zip DoubleMA.zip (37.7 KB, 15 views)
Reply With Quote
 
  #30 (permalink)
 R.I.P. 1960-2010 
 
Futures Experience: Advanced
Platform: NinjaTrader7
Broker/Data: Mirus RCG/Zen-Fire
Favorite Futures: CL & 6e, looking at ES, ZB and AU again.
 
ZTR's Avatar
 
Posts: 2,099 since Nov 2009
Thanks: 1,104 given, 1,390 received


Anyone see this type of error? When someone submits a non-working Indicator I will post the problem if it is something I have not seen before, in advance of my delving into the code blindly.

Andy

Attached Thumbnails
NT7 compatibility-dma.jpg  
Reply With Quote

Reply



futures io > > > > > NT7 compatibility

Thread Tools Search this Thread
Search this Thread:

Advanced Search



Upcoming Webinars and Events (4:30PM ET unless noted)

Linda Bradford Raschke: Reading The Tape

Elite only

Adam Grimes: TBA

Elite only

NinjaTrader: TBA

January

Ran Aroussi: TBA

Elite only
     

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ninjatrader 6.5 june 3rd CME compatibility issue. isarhodes NinjaTrader 5 June 1st, 2011 03:14 AM


All times are GMT -4. The time now is 12:40 AM.

Copyright © 2017 by futures io, s.a., Av Ricardo J. Alfaro, Century Tower, Panama, +507 833-9432, info@futures.io
All information is for educational use only and is not investment advice.
There is a substantial risk of loss in trading commodity futures, stocks, options and foreign exchange products. Past performance is not indicative of future results.
no new posts
Page generated 2017-12-11 in 0.09 seconds with 19 queries on phoenix via your IP 107.20.115.174