[ASK] Multicharts backtesting problem - pls help - futures io
futures io futures trading



[ASK] Multicharts backtesting problem - pls help


Discussion in MultiCharts

Updated
      Top Posters
    1. looks_one jacoGreeff with 3 posts (0 thanks)
    2. looks_two Big Mike with 1 posts (1 thanks)
    3. looks_3 Jura with 1 posts (0 thanks)
    4. looks_4 grausch with 1 posts (0 thanks)
    1. trending_up 3,924 views
    2. thumb_up 1 thanks given
    3. group 4 followers
    1. forum 7 posts
    2. attach_file 0 attachments




Welcome to futures io: the largest futures trading community on the planet, with well over 125,000 members
  • Genuine reviews from real traders, not fake reviews from stealth vendors
  • Quality education from leading professional traders
  • We are a friendly, helpful, and positive community
  • We do not tolerate rude behavior, trolling, or vendors advertising in posts
  • We are here to help, just let us know what you need
You'll need to register in order to view the content of the threads and start contributing to our community.  It's free and simple.

-- Big Mike, Site Administrator

(If you already have an account, login at the top of the page)

 
Search this Thread
 

[ASK] Multicharts backtesting problem - pls help

(login for full post details)
  #1 (permalink)
Cape Town
 
 
Posts: 6 since Mar 2012
Thanks: 4 given, 0 received

Hi Guys

I recently started working on Multicharts and did a few charts importing from ACII.

I am however having problem with backtesting some of the build in strategies. I follow the instructions yet I keep getting the error: DATA FOR NONE OF THE LOADED SYMBOLS IS SUFFICIENT FOR BACK TESTING OR OPTIMIZATION.

I went through all the settings 9 times did all the bar and magnifying settings etc.
The 2 signals I tested out were Bollinger Bands LE and SE.

Hope someone can help me with this.

Reply With Quote

Can you help answer these questions
from other members on futures io?
Work with historical tcks data on MUltichart NET PowerLa …
MultiCharts
If ES tracks SPX, why do support/resistance, Level 2, vo …
Emini and Emicro Index
Short Interest Ratio indicator?
ThinkOrSwim
What blockvolume is visible? - order processing
NinjaTrader
Which kind of Blockvolume is visible? - order processing
Emini and Emicro Index
 
Best Threads (Most Thanked)
in the last 7 days on futures io
Selling Options on Futures?
109 thanks
Battlestations: Show us your trading desks!
108 thanks
Rank your Futures vs Stocks trading priority
55 thanks
Want your NinjaTrader indicator created, free?
27 thanks
Whats this confusion with margins?
23 thanks
 
(login for full post details)
  #2 (permalink)
Site Administrator
Swing Trader
Data Scientist & DevOps
Manta, Ecuador
 
Experience: Advanced
Platform: My own custom solution
Trading: Emini Futures
 
Big Mike's Avatar
 
Posts: 49,785 since Jun 2009
Thanks: 32,313 given, 97,573 received

You need to provide a lot more details. Exact type of data imported, how much of it, length of backtest, etc.

Did you open a chart and confirm the data is valid?

Is it tick data? Minute data? Daily data?

Mike

We're here to help -- just ask

For the best trading education, watch our webinars
Searching for trading reviews? Review this list

Follow us on Twitter, YouTube, and Facebook

Support our community as an Elite Member:
https://futures.io/elite/
Follow me on Twitter Visit my futures io Trade Journal Reply With Quote
The following user says Thank You to Big Mike for this post:
 
(login for full post details)
  #3 (permalink)
Colorado
 
Experience: Advanced
Platform: MultiCharts
Broker: IB & Iqfeed
Trading: ES , CL
 
sptrader's Avatar
 
Posts: 543 since Apr 2010
Thanks: 1,094 given, 696 received


Try a much smaller amount of data ( maybe 15days) and see if it will generate any signals.. and like Mike said- examine to see if the data is there and complete. (Correct order etc)

Reply With Quote
 
(login for full post details)
  #4 (permalink)
Cape Town
 
 
Posts: 6 since Mar 2012
Thanks: 4 given, 0 received

Hi yes the data is working and I can put my signals on the chart to see how it look.

The data is in basic ASCII format and is in 5min intervals i.e.

2009/09/17,08:34:53,23472,23650,23472,23650,41
2009/09/17,08:39:37,23650,23700,23649,23700,74
2009/09/17,08:44:12,23700,23700,23680,23680,54
2009/09/17,08:49:53,23680,23727,23680,23727,19

It goes back to the above date from the current date. I have tried doing a back test with less bars, but get the same error then. I just hate not getting it right because I want to start back testing my own strategy, but can't even get the build in ones to work.

Thanx for the reply's guys.

Reply With Quote
 
(login for full post details)
  #5 (permalink)
The Netherlands
 
Experience: None
Platform: MultiCharts, TradingView
Trading: ...
 
Jura's Avatar
 
Posts: 774 since Apr 2010
Thanks: 2,347 given, 688 received


jacoGreeff View Post
I am however having problem with backtesting some of the build in strategies. I follow the instructions yet I keep getting the error: DATA FOR NONE OF THE LOADED SYMBOLS IS SUFFICIENT FOR BACK TESTING OR OPTIMIZATION.


jacoGreeff View Post
Hi yes the data is working and I can put my signals on the chart to see how it look.

How come your signals work while at the same time you get that error?

Do you have a screenshot or something? What's you MaxBarsBack setting (see Strategy Properties for your signal)?

Reply With Quote
 
(login for full post details)
  #6 (permalink)
Cape Town
 
 
Posts: 6 since Mar 2012
Thanks: 4 given, 0 received


Jura View Post
How come your signals work while at the same time you get that error?

Do you have a screenshot or something? What's you MaxBarsBack setting (see Strategy Properties for your signal)?

my max bar setting at 2000 bars and I was testing it on the build in signal pair that comes with multicharts as stated in first post.

I looked at the signal on my chart and seems to be working on there, but when I go to portfolio backtesting I keep getting that error.

Reply With Quote
 
(login for full post details)
  #7 (permalink)
Luxembourg, Luxembourg
 
Experience: Advanced
Platform: TWS
Broker: Interactive Brokers
Trading: Stocks
 
Posts: 491 since May 2012
Thanks: 1,641 given, 1,149 received


jacoGreeff View Post
DATA FOR NONE OF THE LOADED SYMBOLS IS SUFFICIENT FOR BACK TESTING OR OPTIMIZATION.

I have only 1 day of MC experience, but I had a similar problem yesterday. In my backtester my starting date was set to 2012 while my data is for 2010.

Once I changed that it worked.

Reply With Quote
 
(login for full post details)
  #8 (permalink)
Norwich, UK
 
Experience: Intermediate
Platform: Multiple:research&executi
Broker: Started with Stage5/OEC ... multiple
Trading: Anything found profitable goes ...
 
andby's Avatar
 
Posts: 160 since Jul 2012
Thanks: 87 given, 85 received

Some logged problems regarding Multicharts backtesting / walk-forward optimization which have not been reviewed/commented by Multicharts so far:

MultiCharts Project Management - Issue MC-1026 - Walk-Forward Logic is Flawed
MultiCharts Project Management - Issue MC-1478 - Display Walk Forward Optimization Parameters for next Out of Sample period if incomplete
MultiCharts Project Management - Issue MC-1479 - Continuous Walk Forward Optimization

Visit my futures io Trade Journal Reply With Quote


futures io Trading Community Platforms and Indicators MultiCharts > [ASK] Multicharts backtesting problem - pls help


Last Updated on September 2, 2014


Upcoming Webinars and Events
 

NinjaTrader Indicator Challenge!

Ongoing
 

Battlestations! Show us your trading desk - $1,500 in prizes!

March
 

Importance of Finding Your Own Way w/Adam Grimes

Elite only
 

Journal Challenge w/Jigsaw

April
     



Copyright © 2021 by futures io, s.a., Av Ricardo J. Alfaro, Century Tower, Panama, +507 833-9432, info@futures.io
All information is for educational use only and is not investment advice.
There is a substantial risk of loss in trading commodity futures, stocks, options and foreign exchange products. Past performance is not indicative of future results.
no new posts